close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Form Builder 2 frustrations

Thread began 8/29/2011 11:27 pm by rjbayerl157031 | Last modified 9/06/2011 12:02 pm by Jason Byrnes | 2089 views | 12 replies |

rjbayerl157031

Form Builder 2 frustrations

1. I was having trouble trying to send email with Form Builder 2. I read several posts with not success. I since uninstalled CS5.5 and updated it from Adobe. I reinstalled the Form extension to see if it then would work. Now I can't do anything with it. I get the lovely window saying:
Error initializing Add Form UI
Type error: WAUE_Bundle.checkSerial is not a function.

And I can't go on.

I am also wondering if I need Universal Mail installed. The problem is when I had it there I get there warning saying something like "it seems as if I installed CSS Form Builder while still having Universal Mail installed." I followed the instructions to uninstall Universal Mail and then reinstall Form Builder. I did this and it still happened. I have since uninstalled all Web Assist extensions and reinstalled only Form Builder. Not the above error keeps me from charging on with rebuilding the form and seeing how I get past this impasse.

The other thing is that the WAUE_Bundle above may relate to DataAssist which I had installed at one time this evening and since uninstalled. I'm thinking there is some sort of clean up I must do to fix this.

I use a MacBook Pro with Lion OS. I'm wondering if there is some kind of clean up procedure to do such as might be done with the Windows register. So many questions and I need to get this form up ASAP. Thought it was ready this morning and then the no email issue was there Now can't do a bloody thing!

Please direct me!

Dick Bayerl

Sign in to reply to this post

rjbayerl157031

Still can't get the email to submit

I managed to get the Form Builder working again but still can't get it to send an email. I'm thinking I may have to have Universal Email back in there. Can try that in the morning. I add the info about the email in the Form tab and it stays there until I apply and then it is gone when I go back in. What to do?
Thanks
Dick Bayerl

Sign in to reply to this post

Jason ByrnesWebAssist

You do not need to have Universal Email installed. Universal Email is included as part of form builder.

you will not be able to edit the universal email settings in the form builder wizard after you have already created the form.

to edit the universal email settings go to the server behaviors panel and double click the universal email server behavior.

there are a number of things that cause the email not to send correctly.

Who is your host? in a lot of cases, you can leave the SMTP Server setting blank, but some hosts will require that you enter it.

What have you entered for the from address? many hosts will require that the from address be a valid email address for your domain.

On the SMTP Server settings tab, there is an option to "Include the From address as an extra parameter" depending on your host, you may need to check this.

Sign in to reply to this post

rjbayerl157031

Jason
I do not have currently have Universal Email installed.

So it sounds like I must build a new form after editing the universal email settings. Not entirely sure what will be involved with the editing but right now the only things in Server Behaviors are one line per field name in the form I have now set up. I don't see Universal Email. I will start over with a new form and see what happens. If I start with a fresh web page will the Universal Email behaviors be there?

Thanks.
Dick

Sign in to reply to this post

Jason ByrnesWebAssist

Universal Email will be added if you go to the Form Function tab and check the box to "Send Form Contents in Email"

Sign in to reply to this post

rjbayerl157031

Still no go

Jason
Just once today did I get an email but it was empty. No content.

I went back into the form to check it out and then nothing and nothing after that.

Now I can't get it to keep the email info.

I am trying by starting with a clean web page and inserting a form.

I do the set email info on form function tab and then choose the form I have created profiles for. When I go to DW there is no sign of the email stuff. The form is perfect.

Must I maybe start with a completely new form? That will take a little work but maybe that is it?

I'm surprised, and still quite frustrated, that this is so tricky to get done. If I hadn't invested a bunch of money at Webassist I'd be looking for some other solution.

Question: Under FORM FUNCTION EDIT, what does "Create a file of your email" do. What should I do?

Sign in to reply to this post

Jason ByrnesWebAssist

after the form is created using Form builder, you will not be able to edit the email function through the form builder wizard


to edit the email functions open the server behaviors list:
Window -> Server Behaviors

in the server behaviors list, double click the universal email server behavior to edit it.

  what does "Create a file of your email" do. What should I do?  




the simplest way to get the form information in the email is to check the option to create a file for the email, this creates a file from a template that will loop through the form and send the form information.


if you do not select this option, you need to click the edit button to use Dreamweaver to design the email body.

if you continue to have problems, send a copy of your form page and the webassist/email directory in a zip file.

Sign in to reply to this post

rjbayerl157031

web page and web assist files

Jason,
Here is a zip with the web page and the Webassist/Email folder.

I looked as some of the other folders and it would appear I have it really jammed with stuff from all the attempts I've made.

I'd really like to get this form going by the week end so please see what you can do to help.
Thanks a heap.
Dick

Attached Files
rjbayerl_form_problem.zip
Sign in to reply to this post

Jason ByrnesWebAssist

from what i can see everything looks to be configured correctly.

There are a few questions from my initial reply you have not answered though:

  Who is your host? in a lot of cases, you can leave the SMTP Server setting blank, but some hosts will require that you enter it.  



I can see from your code, that the smtp server address are left blank, like i said, in some cases this is fine, in others you need to enter an smtp server address, you would need to check with host to see if an SMTP server address is required or not when sending an email using a php script, and if it is required, they will be able to tell you what address to use.

  What have you entered for the from address? many hosts will require that the from address be a valid email address for your domain.  



in the code, i see the from address you are using is poppoll@lilies.org, is this a valid address for your domain?


  On the SMTP Server settings tab, there is an option to "Include the From address as an extra parameter" depending on your host, you may need to check this.  



i see that this option has not been checked, you may need to, again, you need to double check with the host to determine if this option is needed or not.

Sign in to reply to this post

rjbayerl157031

Form builder frustration

Jason
Please look at the php file. It has no mention of the email info. Shouldn't it be somewhere on the page? Or is that somehow handled by Server Behaviors?

I just put the smtp server in and it made no difference. Everything looked like it ran correctly but no email.

We use ipower.com.

Dick

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...