close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Menu CSS is not showing

Thread began 8/19/2011 1:48 am by debbie295402 | Last modified 8/19/2011 2:06 pm by Jason Byrnes | 2977 views | 10 replies |

debbie295402

Menu CSS is not showing

I've hit a wall. I've been using CSS MenuWriter forever, but today I did something that doesn't allow the css to show on template pages. Please see www.dsh-solutions.com for the correct page, then just hit any other sub page and the css for the menu isn't showing. Not sure what I did and I've looked at the code for 2 hours now to make sure that the paths are correct. I've checked links and I'm at a loss. Anyone with a fresh pair of eyes willing to give this a go? Or is it a bug?

Sign in to reply to this post

neilo

Only the working page that you link to has been given a <!DOCTYPE . . . > declaration.

They work fine in Firefox, but some browsers will require the DOCTYPE declaration on each page.

Sign in to reply to this post

Jason ByrnesWebAssist

nielo is absolutely correct about the doctype.

IE is the most notorious for needing to have the doctype specified.

when no doctype is specified, IE will go into "Quirks Mode".

In "Quirks Mode" IE will use the IE 5 rendering engine which just barely has support for CSS1

quirksmode.html

Sign in to reply to this post

debbie295402

Actually, they all have a doctype of <!doctype HTML> (html5) but it is located after the template text that dreamweaver put in for it's template use. I've used dreamweaver templates on all my sites and never had an issue... I've removed and readded the menu in case I screwed up the xml file somehow, but nada.

Here's the head info if this helps:
<!DOCTYPE HTML>
<head>
<meta http-equiv="Content-Type" content="text/html;charset=UTF-8" />
<!-- TemplateBeginEditable name="doctitle" -->
<title>Zonta Club of Santa Clarita Valley&nbsp;|&nbsp;&nbsp;</title>
<!-- TemplateEndEditable -->
<script type="text/javascript" src="../scripts/jquery.js"></script>
<script type="text/javascript" src="../scripts/cufon.js">
</script>
<script src="../scripts/TeXGyreAdventor_400.font.js" type="text/javascript"></script>
<script type="text/javascript">
Cufon.replace('h1'); // Works without a selector engine
Cufon.replace('#menu li a'); // Works without a selector engine
//Cufon.replace('#sub1'); // Requires a selector engine for IE 6-7, see above
</script>
<script type="text/javascript" src="../scripts/jquery.js"></script>
<link rel="stylesheet" href="../styles/reset.css" />
<link rel="stylesheet" href="../styles/960.css" />
<link rel="stylesheet" href="../styles/style.css" />
<!-- TemplateBeginEditable name="head" -->
<!-- TemplateEndEditable -->
<script type="text/javascript" src="../CSSMenuWriter/cssmw/menu.js"></script>
<style type="text/css" media="all">
<!--
@import url("../CSSMenuWriter/cssmw/menu.css");
-->
</style>
<!-- TemplateBeginEditable name="menu_ie" -->
<!--[if lte IE 6]>
<style type="text/css" media="all">
@import url("../CSSMenuWriter/cssmw/menu_ie.css");
</style>

<![endif]-->
<!-- TemplateEndEditable -->
</head>

Sign in to reply to this post

Jason ByrnesWebAssist

the doctype MUST be the first tag on the page, if IE sees any html code before the doctype, it will go to quirks mode:

<!-- InstanceBegin template="/Templates/subPage.dwt.php" codeOutsideHTMLIsLocked="false" --><!DOCTYPE HTML>


needs to be rearranged to:
<!DOCTYPE HTML><!-- InstanceBegin template="/Templates/subPage.dwt.php" codeOutsideHTMLIsLocked="false" -->

Sign in to reply to this post

debbie295402

That was the solution. Thanks so much!!

Any idea offhand why dreamweaver would start creating templates this way? This was working throughout but during one of the updates (not sure which one) I got this...

Sign in to reply to this post

Jason ByrnesWebAssist

Sorry, I've not run into an issue with Dreamweaver doing that before, not sure why it would start doing that on you.

Sign in to reply to this post

debbie295402

The thing is that all new pages created from the template need to have the <!DOCTYPE HTML> added. Very weird. probably something I'm missing. Thanks.

Sign in to reply to this post

Jason ByrnesWebAssist

send a copy of your template in a zip file,I may be able to see the cause of the problem if i can see the code.

Sign in to reply to this post

debbie295402

I just found that the opening <html> tag was missing so it screwed up the template and where it put it's editable/lock language. Fresh eyes and no panic really makes a difference!

Thanks for the offer and the help!

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...