close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Captcha missing from form

Thread began 3/18/2009 8:45 am by rmleczynski311091 | Last modified 3/09/2010 1:40 pm by Eric Mittman | 1982 views | 5 replies |

rmleczynski311091

Captcha missing from form

I am trying to use the captcha on the form and when I upload to the site it is not showing the image. If I view the page on my local computer the image shows. I have not changed anything in the original form except for the email address and name. I have put the form itself in a template, but everything seems to be OK. Any ideas?

Sign in to reply to this post

Ray BorduinWebAssist

The code uses the GD2 library to create the image on the fly. It is possible it is not enabled on your remote server. If you try to view the captcha image src location directly will it show? If not the problem is with the GD library not being installed properly on the live server.

Sign in to reply to this post

rmleczynski311091

Found the problem. The font used in the captcha was not getting copied to the server. When I changed the font to one that did get copied to the server, it worked. Thanks for your quick response.

Sign in to reply to this post

westmorelandgraphics311771

I'm having the same problem. How do I go through the process of changing the font to one that gets copied to the server?

Sign in to reply to this post

telegen324627

different problem

The problem i am having is that once i integrate it into my webpage i am not able to see the image but with the raw file that i have downloaded it works fine. I need some help with this

Sign in to reply to this post

Eric Mittman

To use a different font you can change the value in the globals file from this:

$WAGLOBAL_Captcha_Font = "Fonts/MOM_T___.TTF" ;

To match one of the other fonts that are available in the WA_ValidationToolkit > Fonts folder.

If you can see the captcha on the the default page but not the one you add to make sure that the paths for the captcha image match what is on the page, by default the image looks like this:

<img src="WA_ValidationToolkit/WAVT_CaptchaSecurityImages.php

You need to make sure it is in the same directory as the WA_ValidationToolkit folder.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...