close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues


UE4 & Logging - 500 error but get email

Thread began 7/04/2011 4:41 pm by julie383376 | Last modified 7/04/2011 6:28 pm by julie383376 | 821 views | 1 replies |


UE4 & Logging - 500 error but get email

I created a test form, submitted it, received all emails (to, from, cc), and the record wrote to the database.

I then added the functionality to a different form on the same domain. The emails were sent/received, but I got a page that says "HTTP Error 500.0 - Internal Server Error", and no data was written to the database.

So I tried the original test form to see if maybe I had done something wrong in creating this new form, but this form gave the same result as the second form - email sent, 500 error.

This is above my skillset, but my sister (who teaches programming) says it sounds like something that happens with her students a lot - which is, they didn't "close" the connection to the database after writing the record (? - did I say that right?) Could I have done something in my testing that made that happen?

I am an administrator on our webserver, so I set up Failed Request Tracing, and have a logs that you can see if it will help. I only see a warning for event "MODULE_SET_RESPONSE_ERROR_STATUS" in FastCgiModule

It says:

ModuleName: FastCgiModule
Notification: 128
HttpStatus: 500
HttpReason: Internal Server Error
HttpSubStatus: 0
ErrorCode: 0
ErrorCode: The operation completed successfully. (0x0)

There is no other error or warning in the rest of the log.

Can you help? Or do you need more info / screenshots / whatever...?

As always, thank you in advance for your help!


Sign in to reply to this post


Fixed! Missing library.php file

I thought I had looked at all error logs on the server, but I missed one.

The PHP error log showed "Failed opening required 'library.php' "

Sure enough, the script had not installed that file in my webassist/database_management folder

It was in the ..configuration/shared/webassist... (path shortened) location, but it wasn't in my site. I have no idea how the form worked the first time, but after I copied the file into my site, the form submitted, no 500 error page, and it wrote to the database.

I love spending hours and hours and hours troubleshooting (holiday weekend, no less), only to find out that a file that should have been there wasn't...


Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...