close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

60 second script timeout on host

Thread began 6/16/2011 3:35 pm by CraigR | Last modified 6/17/2011 1:50 pm by Lon Winters | 1931 views | 10 replies |

CraigRBeta Tester

60 second script timeout on host

I was having problems with sending a bulk email stopping after about 70 messages

Since I reduced the wait time to 0.25, it works on my host, but when I updated the client site, the process still stops after about 80 messages.

Is this a timeout problem ?

I notice in the code, if the wait time is < 0.25, it is set to 0.25.

How would UE cope with 500 or 1000 mailings ?

I am only looking at about 100, but it is failing for the client 50% of the time

Sign in to reply to this post

Kumel

i had da same prob.. I think u must make the max_execution_time value to 0 (zero)

Sign in to reply to this post

Jason ByrnesWebAssist

there has to be at least a .25 second pause between sending the messages to the smtp server or the smtp server will terminate the connection.

It could be a number of things causing the emails to stop at 80.

It could be a limitation on the server that only allows 80 messages to be sent in a given time frame.

first thing i would try is to add the following code at line 1:

php:
<?php set_time_limit(0); ?>



if you're still having a problem, contact the host to see what limits are in place for sending emails through the smtp server. they may on y allow a certain number in a day, or a certain number every hour.

Sign in to reply to this post

CraigRBeta Tester

On my own hosting server, the script timeout is 60 seconds.

They allow up to 200 emails per hour, and 2000 per day.

At 1 second intervals between messages, the maximum I could send was around 70 messages.

When I reduced the interval, I can send over 200, but I can then reload the page and send another 200.

So I don't think the sending limit is the problem, more the fact that the script is timing out,

I think with my client, the shared hosing may be taking longer to respond during busy times, so with a 60 second timeout, could this shared hosting be a factor ?

In the meantime, I will try your sugggestion.

Thanks

Sign in to reply to this post

CraigRBeta Tester

No luck

I changed line 1 as Jason suggested, I still get the error after about 1 minute.

I checked php.ini to ensure it is not in safe mode, also max execution time is set to 300 in php.ini

I raised a ticket with my host and the reply is as follows...

  All PHP/CGI/Perl scripts are limited to a 60 seconds run time. If your script does not complete during that time, it will be killed  

I find this really frustrating, because I can't test it except in a live environment.

Overall, even if I had 1000 emails to send, would I have to wait for the script to process 3-4 emails a second and wait 5 minutes ?

Is anyone using UE for large mailing lists ? and how are they achieving it ?

Sign in to reply to this post

Jason ByrnesWebAssist

this means that your host has imposed a 60 second time limit regardless of how you set the php.ini file or the set_time_limit setting.


Universal Email will try to adjust that time out setting as well, when sending large email lists, but if the server does not allow for the timeout setting to be changed, then there is not much that can be done for it.

Universal Email wont be able to process large mailing lists on this host, due to the time limit they are imposing.

Sign in to reply to this post

CraigRBeta Tester

Just a final thing on this.

On my host, with a script timeout of 60 seconds, i can squeeze out nearly 200 emails before failure

I can just about live with this limit, but my client says that sometimes only 15 or 20 emails get through on their host.

They are understandable frustrated and are considering setting up with another hosting provider, but I am reluctant to suggest mine, (fatcow) who are generally excellent, but obviously restrictive.

I just checked their php ini with their current hosting provider and execution time is set to 30 seconds - i will take a look at setting the time limit on page.

With shared hosting, is this exacerbated ?

Sign in to reply to this post

Jason ByrnesWebAssist

shared hosting is always more restrictive then dedicated hosting. It could certainly be a contributing factor to the problem.

Sign in to reply to this post

CraigRBeta Tester

sorry, to clarify, can high traffic on a shared hosting site effectively reduce this timeout as the server has less resources to process the script ?

Sign in to reply to this post

Jason ByrnesWebAssist

I suppose that is possible, but high traffic really should not effect a script timing out.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...