close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Save to Remote server after using Datassisst

Thread began 3/23/2011 10:38 pm by cicyou421883 | Last modified 4/22/2011 2:51 pm by Jason Byrnes | 2256 views | 9 replies |

cicyou421883

Save to Remote server after using Datassisst

After completing Data Assist using the Products-Details, I entered data into the design part of the page, After Saving to remote server, localhost, MAMP, The following appeared regarding MAMP. MAMP is on and page is looks good on open the start page and the file name. Before using Data Assist, I was able to upload a file.

MESSAGES as Below

Warning: mysql_pconnect() [function.mysql-pconnect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/content/54/7456454/html/Connections/MAMP.php on line 9

Fatal error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/content/54/7456454/html/Connections/MAMP.php on line 9

NOTE - I did look at Dreamweaver CS3 code and found spaces between lines 7 and 8, eliminated them. Still no go.

Thanx for the help, CATHY

Sign in to reply to this post

Jason ByrnesWebAssist

what did you enter for the MySQL Server name in the connection file? Try using the local loop back address:
127.0.0.1

instead of localhost.

if that does not solve the problem, see this page for details:
solve-cant-connect-to-local-mysql-server-through-socket-tmpmysqlsock/


In some cases, I have had people report that the only way to fix the issue was to re install MAMP

Sign in to reply to this post

cicyou421883

Tried 127.0.0.1

Jason, I went to Data Assist and changed MAMP localhost to 127.0.0.1

Still the same error. Without using Data Assist, MAMP worked fine.

Here is the string in Dreamweaver Lines 1-26

<?php require_once('Connections/MAMP.php'); ?>
<?php require_once("WA_DataAssist/WA_AppBuilder_PHP.php"); ?>
<?php
if (!function_exists("GetSQLValueString")) {
function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "")
{$theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;
$theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);
switch ($theType) {
case "text":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "long":
case "int":
$theValue = ($theValue != "") ? intval($theValue) : "NULL";
break;
case "double":
$theValue = ($theValue != "") ? "'" . doubleval($theValue) . "'" : "NULL";
break;
case "date":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "defined":
$theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;
break;
}
return $theValue;

Sign in to reply to this post

Jason ByrnesWebAssist

this is an issue in the MAMP configuration when creating a database connection.

t is an issue between the PHP server and MySQL server. the basic PHP functions my be working fine, but there is an issue when trying to create the database connection to the MySQL server.


did you go to the site that I linked to:
solve-cant-connect-to-local-mysql-server-through-socket-tmpmysqlsock/


ultimately, this boils down to a server configuration issue.

you would the same error message if you try to create a basic Dreamweaver recordset.

Sign in to reply to this post

cicyou421883

MAMP is working fine except for using Data Assist

Jason - Thank you for your reply. MAMP is working when I use it. I have posted php to MAMP already. When I use Dataassist, it eliminated my CSS files on the page and would not post. I did look at your link and first page of Data Assist switched it. Nothing changed. At this point, with all webassist product, I get errors that i do not get when I just use Dreamweaver CS3. I am new to database but this should be easier.

Sign in to reply to this post

Jason ByrnesWebAssist

I agree that this is a frustrating issue, but it is not related to data assist.

the issue is in creating the connection between the PHP server and the MySQL Server.


here is a test:

Create a blank page and add a Dreamweaver recordset to it, you will find you have the same error.

In a number of cases where people have had this issue before, the fix was to uninstall, then reinstall mamp.

Sign in to reply to this post

cicyou421883

Mamp

Jason, as per your suggestion, I uninstalled and reinstalled MAMP. No luck. I also found out that OS X 10.6.7 did not have the client libraries and binary folder installed, so I updated that. I also had to activate in Dreamweaver the firewall and check that on the remote server.

As this point, MAMP will not let me check the Apache and MySQL ports change in preferences to 80 and 3306. Both red lights turn on. When I reset to MAMP ports 8888 and 8889, both green lights go on.

I also tried to configure with G0Daddy Database and use Dreamweaver CS3. I have not made a connection there either since the error says there is not testing server on this machine - which i set up to the remote server IP address and it tests fine except for using a database.

I have not seen the original error /tmp/mysql.sock as per your post since the upgrades to OS X 10.6.7 and the install of MySql on my computer.

Please advise as to how to get the localhost MAMP to the ports that I need (80 and 3306)

I need this in order to use Datassist and e-cart features and do not know why I cannot get the features to work. Thanx

Sign in to reply to this post

Jason ByrnesWebAssist

you should post to the map forums for issues regarding configuring mamp:
forum.mamp.info/

Sign in to reply to this post

cicyou421883

Socket Problem again

Hey Jason, Thank you for the conversation on Wednesday. I spent the rest of Wednesday and all of Thursday cleaning up the root and hosts directory of my Computer. I am back to this original issue of:

Warning: mysql_pconnect() [function.mysql-pconnect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/content/54/7456454/html/Connections/canaturalmysql.php on line 9

Fatal error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/content/54/7456454/html/Connections/canaturalmysql.php on line 9

MAMP PRO is working fine,

You showed me how to look code on my connections string in Dreamweaver CS5. I can only reference localhost and I could not put and save the remote server as per your instructions (You referenced Dynamic Connections)

I tried to create and /etc/my.cnf by copying the MAMP PRO template and that did not work. I also tried to understand the datadir and the basedir and cannot understand where to apply.

I do understand that the /var/lib/mysql/mysgl.sock does not exist on my computer and that the tmp/sock is within MAMP. I cannot figure how to get the computer to understand this and that is why I ended up confusing my computer, hence my last problem.

Obviously I need the database string to work in order to get this website up using Web Assist.

I am also talked to Lauren about this continued issue and she is responding to my question of upgrading to Super Suite.

Thank you for anything you can do to help me get the first php page finally online.

Sign in to reply to this post

Jason ByrnesWebAssist

are you getting this error testing locally or remotely?


If this issue is happening locally, it is a MAMP installation issue, you will need to contact MAMP support for assistance with this.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...