close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Checkout.php problems

Thread began 2/17/2011 1:06 pm by sabastian130416448 | Last modified 2/18/2011 10:15 am by Jason Byrnes | 1098 views | 6 replies |

sabastian130416448

Checkout.php problems

Hey guys I am in a bit of a bind.

I created a website with Ecart and it is working fin. Address is www.henkor.co.za

The thing is I have now used security assist on my shop pages, wich arent on the
site yet, and now my checkout.php doesnt get the user info when you go from cart.php
to checkout.php

I have attached the cart.php and checkout.php pages.

If I create a new checkout.php page with the wizzard it says that the header has already been loaded.

Checkout2.zip is the page befor I removed the restrict access recordset to the page.

Thanx

Attached Files
cart.zip
checkout.zip
checkout2.zip
Sign in to reply to this post

sabastian130416448

If any other info is needed please let me know.

Sign in to reply to this post

Jason ByrnesWebAssist

the error is caused by the blank line be=tween php code blocks at line 2:

php:
<?php session_start(); ?> 


<?php




be careful of blanks line between php code blocks.


can you send a copy of your login page, so i can see how that is set up.

Sign in to reply to this post

sabastian130416448

Here is my shop home page, users log in and users registration pages if they are needed.

I fixed the spaces but now I get this error.

Warning: Cannot modify header information - headers already sent by (output started at C:\Users\Henkor\Desktop\henkorsite\checkout.php:2) in C:\Users\Henkor\Desktop\henkorsite\checkout.php on line 51

Any solutions?

Thanx.

Attached Files
shop-home.zip
users_LogIn.zip
users_Registration.zip
Sign in to reply to this post

sabastian130416448

I took out the Restrict access to page server behavior then it doesn,t give me the error but it still doesn't enter the users info like it should.

Sign in to reply to this post

sabastian130416448

hey Jason.

I got the page to work. I had a previous thread where I also had trouble with this subject and realised that I had to change my filter settings in my recordset.

I have a new thread where I have trouble with a message showing "Loged In As ???"
and that is where the trouble comes in. The name doesn't want to display.

If you can have a look at it cause the relevant pages are attached on the thread and help is needed.

Thanx

Sign in to reply to this post

Jason ByrnesWebAssist

Ok, glad to hear it is working, I will look into the other thread as well.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...