close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Shipping Quote error

Thread began 2/07/2011 5:47 pm by windsoarer388279 | Last modified 4/13/2011 2:39 pm by Jason Byrnes | 1953 views | 13 replies |

windsoarer388279

Shipping Quote error

Is there any support refrences for the shipping errors?

I'm getting a "UspsCom::DoAuth" error and there is no listing of this on USPS support.

Also can the shipping details be altered after wizard creation? Such as packaging.

Thanks in advance.

Steve

Sign in to reply to this post

windsoarer388279

OK, got the credential location figured out. That is under the USPS server behavior in the confirm page.

As for the other issue, awaiting clarification from USPS as it may be related to the testing server not handling any calls except for specific "canned" tests. Will post back as soon as it is clarified.

Would still be helpful to have some information on shipping, like the transaction error guide and sandbox testing.

Sign in to reply to this post

Jason ByrnesWebAssist

On the bindings panel, expand the USPS binding group and add the Full Response binding to your page. This will write the full responses from USPS to the page which should contain more details about the problem.

Any documentation about the errors and there meaning will be found on the USPS website.

Sign in to reply to this post

windsoarer388279

I added the full Response to my page and found that the API address was incorrect from what was provided by USPS, so I updated that.

USPS provides information on the API but is only for RateV4 while the tools provided here are RateV3.

The system now works, but the RateV4 reference materials provided by USPS do not match the webassist RateV3 programming.

This is above my coding knowledge, hence using webassist, and may need to be updated to reflect the USPS new API.

Sign in to reply to this post

Jason ByrnesWebAssist

We are in the process of updating the USPS code to use the new V4 API. the V3 api will not be retired until May, we will issue updates before then.

Sign in to reply to this post

windsoarer388279

Thank you, that gives me a better feeling knowing an update is coming.

Sign in to reply to this post

bjackson5375693

More info needed

Originally Said By: windsoarer388279
  OK, got the credential location figured out. That is under the USPS server behavior in the confirm page.

As for the other issue, awaiting clarification from USPS as it may be related to the testing server not handling any calls except for specific "canned" tests. Will post back as soon as it is clarified.

Would still be helpful to have some information on shipping, like the transaction error guide and sandbox testing.  



Can you give some more info on how you fixed this error?

Sign in to reply to this post

Jason ByrnesWebAssist

On the bindings panel, expand the USPS binding group and add the Full Response binding to your page. This will write the full responses from USPS to the page which should contain more details about the problem.


post back the full request and full response so we have a better understanding about what is failing in order to give advice on how to fix it.

Sign in to reply to this post

bjackson5375693

Originally Said By: Jason Byrnes
  On the bindings panel, expand the USPS binding group and add the Full Response binding to your page. This will write the full responses from USPS to the page which should contain more details about the problem.


post back the full request and full response so we have a better understanding about what is failing in order to give advice on how to fix it.  



Hello Jason,

I added the full error description to the page. The error message I get is

80040b1a Authorization failure. Perhaps username and/or password is incorrect. UspsCom::DoAuth

I have double checked my username and it is correct. I don't find a location to enter a password for USPS.

The only fields asked are userID and then there is an xml server address. The address listed in my program is shippingapi.dll

Thanks,

Bryan

Sign in to reply to this post

Jason ByrnesWebAssist

.it may be that your account has not been authorized to connect to the production server, try using this as the xml server address:

shippingapi.dll

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...