close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

PowerCMS 2 template not working

Thread began 2/02/2011 4:16 pm by tkendrickmail32213 | Last modified 2/07/2011 10:39 am by Jason Byrnes | 1237 views | 5 replies |

tkendrickmail32213

PowerCMS 2 template not working

When i created a new page based on a PowerCMS template, the content remains exactly the same. See test.php and test.php?test=1

This is a bug. I bought this specifically for a client who had such a need. Is there no other way to get support? I'm dead in the water here and have spent hours trying to figure this out.

Sign in to reply to this post

Jason ByrnesWebAssist

it is differant if you change the URL variable to 2:
test.php?test=2

Sign in to reply to this post

tkendrickmail32213

logic

Thanks, this helps.

Developer notes says:

Since this page is based on a template, you don't have to copy the Developer Notes to a new PHP page to view this content. Instead, add the following line to the end of the URL for the page that displays the template's content.

?test=1

The address/URL to view this content should look something like this:
template.php?test=1

What is the logic for future posts. I have a client who will post hundreds of pages based on this template. Do i keep adding another number to the end?

I added another page based on this template, and now 2 is the same, and 3 is different.

Sign in to reply to this post

Jason ByrnesWebAssist

yes, the number at the end of the URL will change for each new page you add based on the template, it is the number at the end that tells the system which page to load.


For each new page you create based on the template, look at the developer notes, you will see the number at the end of the URL change to give you the correct number to use to load that particular pages content.

Sign in to reply to this post

tkendrickmail32213

understood

I understand how the number at the end correspondes to the new tempate being added in the developer notes, but it is not working correctly. In the previous corresondonce, you mentioned adding a "2" but the developer notes here said "1". I think this is a bug.

Sign in to reply to this post

Jason ByrnesWebAssist

For each new page you create form the template, the developer notes will contain the correct number for that particular page only.

The developer note for the main page will show 1, but if you select one of the other pages from the template and view the developer notes, it will show a different number.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...