close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

CSS form builder and html editor error

Thread began 1/28/2011 12:05 am by Miguel | Last modified 2/17/2011 2:41 pm by Jason Byrnes | 1643 views | 4 replies |

Miguel

CSS form builder and html editor error

Hello i think i found a very annoying bug on the css form builder 2 when i activate it to use html editor with file managment, already happening to me on 2 sites im building, after making the forms and selecting the field that contains the html editor selection file management then selecting which conection to use and then Allow access to option, if i have 2 diferent tables for example one for users and another one for admin panel, when i go and test the page and hit the icon called "insert image" it popups the image propertie box, in there i click on check on the server and there it throws me this error:

The server didn't reply with a proper XML data. Please check your configuration

i checked and compared to other sites i made with the only difrence that on the sites where it works fine theres only one tables that manages both users and admins and on the sites it doesnt work is where i manage independant tables one for normal users one for admins.

I manage to make one of the sites that had this problem work the thing is that i modify so much the code on the helper_PHP.php and HelperGroupsRulesPHP.php and html editor config.php spent the hole day testing and changing that i dont remeber what change i did made it work, but still i try to apply those files changing the callings for the other sites but still without luck.

Also testing the page i was login as an admin also tested as a user and so on have lost a hole day cause of this bug hope WA can duplicate the bug so it can get fix.

now the normal upload on the third tab of the image propertie box no matter what it never uploads the files i try to upload that way even with the html editor working check error-2.png it stays there stuck until i close that box and does not upload any picture

If there is any work around if these bugs are already known please let me know what to do im very frustrated with them.

Sign in to reply to this post

Jason ByrnesWebAssist

I am trying to replicate this problem, but cannot.


Can you give some more details on how the access rules where created to cause the issue?

If I had some specific details to follow for creating access rules that trigger the problem it would be helpful.

Sign in to reply to this post

Miguel

Ok table for normal users

CREATE TABLE IF NOT EXISTS `UserTD` (
`IDC` int(11) NOT NULL AUTO_INCREMENT,
`userEmail` varchar(150) NOT NULL,
`passD` varchar(150) NOT NULL,
`Nombre` varchar(100) NOT NULL,
`Apellido` varchar(100) NOT NULL,
`Telefono` varchar(30) NOT NULL,
`Celular` varchar(30) DEFAULT NULL,
`Direccion` varchar(300) NOT NULL,
`Cedula` varchar(150) NOT NULL,
`Registrado` timestamp NULL DEFAULT CURRENT_TIMESTAMP,
`Estatus` tinyint(1) DEFAULT '1',
`activacion` varchar(200) DEFAULT NULL,
PRIMARY KEY (`IDC`)
) ENGINE=MyISAM;

CREATE TABLE IF NOT EXISTS `Administratorz` (
`idSuper` int(8) NOT NULL AUTO_INCREMENT,
`email_sup` varchar(150) NOT NULL,
`passd_sup` varchar(150) NOT NULL,
`Nombres_sup` varchar(200) NOT NULL,
`Nivel` tinyint(1) NOT NULL DEFAULT '1',
PRIMARY KEY (`idSuper`)
) ENGINE=MyISAM;

I then apply security assist wizard twice one for the user tables another for the admin table

The admin php are located inside an admin folder

localhost/sitename/adminfolder/

I also followed the how to do the sha1 encrypting everything works well less the html editor the rules right now i romoved the level access have it normal for admins:

Name: Logged in to Admins

Allow selected

Value: <?php echo $_SESSION['idSuper']; ?>

Criteria: <>

Compare to: nothing here empty

***************************************************
Normal users rules

Name: Logged in to clientes
Allow selected
Value: <?php echo $_SESSION['IDC']; ?>
Criteria: <>
Compare to: empty nothing here this one also has:

Allow selected
Value: <?php echo $_SESSION['Estatus']; ?>
Criteria: =
Compare to: 1

*****************************************************

On html Editor on Global File Upload Settings:

Enable file managmente: checked
Upload directory: /imagenes/
Advance file mangement: My conecction selected

Security:
Allow access to: Logged in to Admins

Fail redirect: /Entrar.php

Other things i have on my administration page they are with a template and that template i apply Frames work builder with a theme created for the template.

If i remove the advance file managment it works but without all the crop options

I went live already with the promise to solve the issue soon but had no luck yet on a fix have try everything also i notice this is also happening on other sites where i have a template with theme apply to the page those that i dont apply it work, could it be something witht he framework builder?

I also notice when trying to open the image manager on html editor it shows this link on top

browser.php?Type=Image&Connector=http%3A%2F%2Fdomainname.com%2Fwebassist%2Fhtml_editor%2Feditor%2Ffilemanager%2Fconnectors%2Fphp%2Fconnector.php

Sign in to reply to this post

Miguel

If i upgrade to html editor 3 would this correct the bug?

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

Sign in to reply to this post

soundshape

The server didn't reply with a proper XML data. Please check your configuration.

I've duplicated this error on two different sites. The File Management worked when I first deployed the HTML Editors. I didn't change a thing...and some of the editors on some forms throw the same error, while other form with editors, launch the file manager without a problem - on the same site. I have verify the local and server files are identical. I have set FTP permisions to 775.

I upgraded to DataBridge 1.1.0 and was able to get tsome broken forms working again, however; I now will have to update all forms with an HTML Editor for consistency. Thank you so much for wasting my time and creating duplicate work. WebAssists support has been no help. Great job guys!

Sign in to reply to this post

Jason ByrnesWebAssist

Do you want us to look into the problem with you?

we certainly are not trying to waste your time, nor create duplicate work, but i'm not sure how we could have helped you with this issue since you have not asked for help until now...

I'll be happy to set up a support incident so we can investigate the problem with you if you like.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...