close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Solution recipe wizard errors

Thread began 12/21/2010 3:59 pm by FrankJay | Last modified 12/21/2010 8:24 pm by Ray Borduin | 823 views | 1 replies |

FrankJay

Solution recipe wizard errors

I am using SecurityAssist to create a complete registration and access system. In step one of the wizard I select a template and editable region. When I move to step two of the wizard I get an error "error: object expected. See attached screenshot. I've found a thread [ showthread.php?t=7706&highlight=object+expected]
1.mentioning a possible JavaScript error in the template, and
2. Disable preview in WebAssist preferences. I made this changes, rebooted, ran the wizard again with the same result of the error message being displayed.
My total lack of knowledge about JavaScript leaves me helpless. The error message refers to line 120. However, on my template page ends on line 95.

I include all the JavaScript on my template page, namely:
<script type="text/javascript" src="../includes/CSSLayouts/debug_plus.js"></script>
<script type="text/javascript" src="<?php echo $xtd_cm_relpath; ?>includes/Creative_Menus/menuDisplay.js"></script>
<script type="text/javascript" src="<?php echo $xtd_cm_relpath; ?>includes/Creative_Menus/swfobject.js">
<script type="text/javascript"> buildMenu() </script>

These are all the JavaScripts on my template page. Kindly advise which could be the problem script, pls suggest solutions.

I complete the wizard and select option 'no' each time the "error: object expected" pop-up box displays. When completing the other steps of the solution recipe I also get this additional error/problem ""Making this change would require changing code that is locked by a template or a translator. The change will be discarded."

When I ran the solution recipe steps and apply no template, I do not experience any of the above problems.

Any ideas and solutions to the above is greatly appreciated.

Sign in to reply to this post

Ray BorduinWebAssist

I think the preview may be incompatable with your template files because of the dynamic script links.

Run the wizard on new pages without using a template in the wizard and then apply your template after the wizard has completed and you should be able to avoid this issue, or try turning off the preview from Edit->Webassist Preferences.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...