close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Data Assist2 Not Work -

Thread began 11/13/2010 4:01 pm by paolo410517 | Last modified 11/17/2010 2:43 pm by Jason Byrnes | 1233 views | 9 replies |

paolo410517

Data Assist2 Not Work -

Greetings all, I recently purchased Super Suite, so I ask a little patience if my questions are of base type.
I'm using Super Suite - WebAssist, I created a sample database, and a simple table, to see how the wizard. I studied the site all phases of start-ups, but there is something that generates errors.

In MySQL DB, the table looks like this:
- idnome (integer 11)
- name (varchar 30)

from Wizard, I created the pages (by following the instructions of the WebAssist site):
- Results
- Search
- Detail
- Update
- Insert
- Delete

The records are listed by Results php file, but if I try to update a record I get the following error message:

Unknown column 'undefinedpaolo1undefined' in 'field list'

I have attached the file that the wizard has written and the database with its table.

I kindly ask you to give me some help. Thanks.

***********************************************

Attached Files
TableMySQL_webassist.txt
webassist.zip
Sign in to reply to this post

Dave BuchholzBeta Tester

Paolo,

Your issue is caused by line 56 on 04webassist_Update.php which reads:

php:
$WA_columnTypesStr = "undefined";



This should read something like:

php:
$WA_columnTypesStr = "',none,''"



for a text based field.

Try running the wizard again and if you still get the same results then I would suggest that you need a WA engineer to look at the issue as it may be something in your set-up that is causing it.

Sign in to reply to this post

paolo410517

Hello Dave,
you have been very kind, thank you.

I made the change that I've written, now the script works correctly.

The Wizard of creation (I think it is very easy, considering that my experience comes from the now defunct estension Interakt !!!!!) I tried to give the variable NAME = Type the text, but the result was not taken into account at the end of Wizard.

I have tried to change the Type by the Update Wizard (after the creation I made double click on Update Record (04webassist) from tasck Dreamweaver) but to no avail! In fact, the script did not work.

This is the result of putting text in the Data Type of Step 2 in the editing stage of the Update Wizard

$ WA_where_columnTypesStr = "none, none, NULL";

This code produces the following error in the script:

Incorrect table name''

But now what do I do? because if you try again the Wizard continues to produce the code incorrectly? I think it's a problem of WebAssist! What should I do?

Sign in to reply to this post

Jason ByrnesWebAssist

can you send a copy of the latest update page so I can examine the code.

Sign in to reply to this post

paolo410517

To facilitate the display of all the wizard I created a PDF file, but since your board does not accept more than 293 KB, I had to split into multiple pages:

These attachments are the monitor screen for the Wizard
list_wizard_pag_1e2.zip
list_wizard_pag_3e4.zip
list_wizard_pag_5e6.zip
list_wizard_pag_7e8.zip
list_wizard_pag_9e10.zip
list_wizard_pag_11e12.zip

This zip file contains the list of products from the Wizard, with no changes
04webassist_lista_files.zip

This zip file contains the 04webassist_Update, as amended by clicking on the Dreamweaver Server Behaviors
04webassist_Update_Modificato.zip

I hope I was clear in the exposition of the problem, I await feedback.


**************************************


Per facilitare la visualizzazione di tutto il wizard avevo creato un file PDF, ma dato che il vostro forum non accetta più di 293 KB, ho dovuto dividere in più pagine:

questi file allegati sono gli screen monitor relativi al Wizard
list_wizard_pag_1e2.zip
list_wizard_pag_3e4.zip
list_wizard_pag_5e6.zip
list_wizard_pag_7e8.zip
list_wizard_pag_9e10.zip
list_wizard_pag_11e12.zip

questo zip contiene la lista dei file prodotti dal Wizard, senza alcuna modifica
04webassist_lista_files.zip

questo zip contiene il file 04webassist_Update, modificato facendo click su Comportamenti Server di Dreamweaver
04webassist_Update_Modificato.zip

Spero di essere stato chiaro nella esposizione del problema, attendo riscontro.

Attached Files
04webassist_lista_files.zip
list_wizard_pag_11e12.zip
list_wizard_pag_1e4.zip
list_wizard_pag_5e8.zip
list_wizard_pag_9e10.zip
Sign in to reply to this post

Jason ByrnesWebAssist

change this line:
$WA_table = "`04webassist`";


to:
$WA_table = "04webassist";

Sign in to reply to this post

paolo410517

Sorry but your answer is not very clear!

If I make the change, by manually editing the code, the script works. This
means that every time I need to edit the code produced by the Wizard?

Sign in to reply to this post

Jason ByrnesWebAssist

the issue is caused by the naming convention used for your table.


table names should contain only letters, no numbers should be used in the tables name.

Sign in to reply to this post

paolo410517

Valuable support,
I did the tests you requested:

1) I renamed the MySQL Name Table, removing the numbers

2) I reloaded the wizard WebAssist

3) I have attached the files to your PHP extension products from the MySQL DB

But, unfortunately, unsatisfactory ........

The Wizard continues to create the PHP code in a wrong way, because the variable

$ WA_columnTypesStr = "undefined";

continues to be produced undefined. Have you a correction Bug in your extension?













pregiatissimo supporto,
ho fatto le prove che avete richiesto:

1) ho rinominato la Tabella di MySQL, togliendo i numeri

2) ho caricato nuovamente il wizard di WebAssist

3) ho allegato i file in PHP prodotti dalla vostra estensione + il DB MySQL

Però, Purtroppo, insoddisfacente........

Il Wizard continua a creare il codice PHP in una maniera errata, infatti la variabile

$WA_columnTypesStr = "undefined";

continua ad essere prodotta undefined. Avete previsto una corezzione nella vostra Estensione?

Attached Files
db_table_webassist.txt
prova_renameTable.zip
Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...