close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

404 error on products menu

Thread began 11/02/2010 2:25 am by 12.bernie410015 | Last modified 11/03/2010 11:33 pm by 12.bernie410015 | 834 views | 5 replies |

12.bernie410015

404 error on products menu

PS 4.01
Side product menu working, all of the Product menu items fail with 404 error.

The requested URL /products_results.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

see glamourup.com

I attempted to implement showpost.php?p=78449&postcount=16
this did not fix the problem. I did rename the original files before I uploaded the files in the referenced fix. When the fix failed I deleted the file new files and move the old files back into place.

I did also reload the page to clear the cache.

Thanks

John

Sign in to reply to this post

Jason ByrnesWebAssist

the fix seems to be in the results.php and results_grid.php under webassist/plugins/catalog/ folder and changing this line of code:

$currentPage = dirname($_SERVER['PHP_SELF']) . '/' . $currentPage;

to

$currentPage = dirname($_SERVER['PHP_SELF']) . $currentPage;

Sign in to reply to this post

12.bernie410015

404 errors still present

The files I had on the server did not have the line you wanted changes.

I moved the two files from the /install/webassist/plugins/catalog director from the 4.0.1 upgrade file the two files that needed to be changed and made the change. It did not seem to work. I also did clear the cache.

See www.glamourup.com >Products > Select All - this will give you the error. So will going to any of the sub-menus under Products

Thanks

John

Sign in to reply to this post

12.bernie410015

404 errors still present

Sorry I should have attached the two files for your review just in case you needed them.

John

Attached Files
Archive.zip
Sign in to reply to this post

Dani Chankhour

It looks to me that you have not uploaded your product results page to your server. Please make sure to upload all the files to your server. If you are using an ftp client, please make sure that you see a products_results.php page in the root of your site.

Sign in to reply to this post

12.bernie410015

thank you

The file was in the root directory but the name was Products instead of products. Thanks for the lead.

Problem resolved.

John

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...