close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

In category display products_results.php becomes root during Next and Last from Side

Thread began 10/29/2010 8:13 pm by jefflamrouex | Last modified 11/01/2010 6:42 pm by jefflamrouex | 5449 views | 10 replies |

jefflamrouex

In category display products_results.php becomes root during Next and Last from Side

Greetings -

I need some help on a small problem with the site dacfeedstore.com

Show all products links work fine, and the top links to the product categories work fine, but when using the sidemenu, and the number of products exceeds one page (presenting a 'Next' and 'Last' link) clicking on the 'Next' links tries to jump to, for example using 'High Performance Horses', "http://products_results.php/?pageNum_WADAProducts=1&totalRows_WADAProducts=10&Search=1&ProductCategoryID[]=8"
instead of
"http://dacfeedstore.com/products_results.php?pageNum_WADAProducts=1&totalRows_WADAProducts=10&Search=1&ProductCategoryID[]=8

Thanks in advance for the help. We're really liking PS4

-Jeff Lamrouex-

Sign in to reply to this post

Jason ByrnesWebAssist

see this post for files to fix the issue:
showpost.php?p=78449&postcount=16

Sign in to reply to this post

jefflamrouex

Same problem remains after applying fix

Thanks for the the reply and files, Jason, but the same problem remains unscathed.

Other thoughts?

Best Regards,
-Jeff-

Sign in to reply to this post

Jason ByrnesWebAssist

I am testing your site at the link you provided in the initial post and it is working for me. Perhaps, you need to clear your browsers cache.

Sign in to reply to this post

jefflamrouex

Problem still exists after clearing, etc.

Originally Said By: Jason Byrnes
  I am testing your site at the link you provided in the initial post and it is working for me. Perhaps, you need to clear your browsers cache.  



Hi Jason,

First, thanks for the reply.

That's what I thought it might be also, so I cleared all caches with the same results. I also downloaded and ran fresh browsers on this and another OS, and tried the same thing on an alien machine. Same results. Not to be redundant, but here's the specific formula to see what I mean:

Navigate to the Home page of dacfeedstore.com

Click the Products menu at the top to display all products

Click the side menu "High-Performance Horses"

Click either 'Next' or 'Last' to the right of breadcrumbs 'Products 1 to 9 of 10'

Error (link tries to go to products_results.... instead of products_results....

Also, any menu selections made from the top 'Products' menu only, are fine. All the submenus, including the one listed above work just fine.

But, if you click at any time on one of the side menus that exceed one screen, the link is wrong.

Thanks again,
-Jeff-

Sign in to reply to this post

Jason ByrnesWebAssist

did you download the 4.01 power store update that is available from the download center?

Sign in to reply to this post

jefflamrouex

2.02 ?? Using PowerStore 4.0.1

Jason -

We're using PS 4.0.1 for this site.

Thanks,
-Jeff-

Sign in to reply to this post

Jason ByrnesWebAssist

ghaa, getting products and their versions mixed up.


Those files i linked to should fix the problem.

try uploading them once again, this time though, add today's date after the body tag first so we can verify that the upload is going up correctly.

Sign in to reply to this post

jefflamrouex

Date added; appearing near breadcrumbs; same result

Originally Said By: Jason Byrnes
  ghaa, getting products and their versions mixed up.


Those files i linked to should fix the problem.

try uploading them once again, this time though, add today's date after the body tag first so we can verify that the upload is going up correctly.  



Hi Jason -

I added the date as requested to verify uploaded files.

No change from this side.

Thanks again for looking at this for me.

-Jeff-

Sign in to reply to this post

Dani Chankhour

the fix seems to be in the results.php under webassist/plugins/catalog/ folder and changing this line of code:

$currentPage = dirname($_SERVER['PHP_SELF']) . '/' . $currentPage;

to

$currentPage = dirname($_SERVER['PHP_SELF']) . $currentPage;

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...