close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

PowerStore4.0.1 update?

Thread began 10/18/2010 11:59 pm by mick106153 | Last modified 10/27/2010 6:24 pm by 12.bernie410015 | 1141 views | 7 replies |

mick106153

PowerStore4.0.1 update?

I see there has been a PowerStore 4.0.1 update.
I am surprised there was no notification.
Does this address the issues most of us had when we installed v4 - case issues and the like?

Mick

Sign in to reply to this post

Ray BorduinWebAssist

It should address all of the reported issues. Case issues are certainly on that list. The update was put up last night. An announcement should go out today.

Sign in to reply to this post

annedawn345445

cart not working in 4.0.1

I wrote over my 4.0 files with the update files and now a site I am testing locally allows me to do admin, but on the product portion of the site, add-to-carts are showing a blank page for cart.php.

Any thoughts.

Sign in to reply to this post

Ray BorduinWebAssist

We will be updating the upgrade instructions at: updating_401.php

and make sure to add the extra steps we went through over the phone of copying the install/webassist folder to the root and setting permissions.

Sign in to reply to this post

12.bernie410015

PowerStore 4

Folks,
I purchase PS3, then upgraded to 4 and have struggled with 4 from day one. I think everyone is aware of the major issues with PS4 which make it unuseable. I am elated to see that PS4.1 is now available but I cannot believe there is a charge for it to upgrade. I paid for PS4 and it did not work please don't charge me again. How can I get the upgrade without spending another $299 on top of my version 3 investment of $299 and my version 4 upgrade of $174. I have already spent full price and still have nothing usable and no assurance that 4.1 is stable.

John

Sign in to reply to this post

siteontimeBeta Tester

To my knowledge there is no additional charge for 4.01 . I have never seen webassist charge for update to an existing release number.

4.01 should be available for you to download in your account downloads under Powerstore 4. The files have been replaced and the new download is 4.01 . There is also a link for instructions on upgrading from 4.0 to 4.01.

I upgraded to 4.01 yesterday with no issue at all.

Hope that helps.

Sign in to reply to this post

12.bernie410015

Errors on upgrading to 4.01

I followed the update instructions through step 6 and all seemed to be well.

On step one to run the v4.0.1_update.sql, I copied this to the install /scripts directory ( I did notice that the PowerStore401/PowerStore Files/install/scripts on my PC had the following files.
connection.php size 510 date 9/16/2010
db.sql size 89480 data 10/14/2010
index.php size 0 date 4/13/2010
v3_v4_update_script.sql 91,021 date 10/13/2010
v4.0.1_update.sql size 14,855 date 1-/14-2010

The /install/scripts directory on the server had the following files
connection.php size 510 date 9/16/2010 (same on both machines)
db.sql size 74579 date 09/20/2010 (note different file size and date)
index.php size 0 date 4-13/2010 (same on both machines)
v3_v4_update_script.sql size 76,514 date 9/21/2010 (note different size and date)
v4.0.1_update.sql size 14,855 date 10/26/2010 (note I ftp'ed this file to the server

The upgrade instructions do not call for any file being updated in the /installs/scripts directory. It does say to run the v4.0.1_update.sql file. When I do this I get the following errors:

SQL query:

INSERT INTO `ps4_contents` ( `ContentID` , `ContentGroup` , `ContentRefID` , `ContentValue` , `ContentDate` , `ContentUserID` , `ContentPageName` , `ContentPageSetParentID` , `ContentPageSetOrder` , `ContentType` , `ContentParentGroup` )
VALUES (
'78', 'Home Page', 'meta-keywords', 'home', '2010-09-27 11:21:10', '0', '', NULL , '1', 'WYG', NULL
);

MySQL said: Documentation
#1062 - Duplicate entry '78' for key 1

*********************************

I then tried to run the sql provided in the upgrade instructions and got the following errors:
import.php: Missing parameter: import_type (FAQ 2.8)
import.php: Missing parameter: format (FAQ 2.8)

FAQ 2.8 SAYS 2.8 I get "Missing parameters" errors, what can I do?

Here are a few points to check:

* In config.inc.php, try to leave the $cfg['PmaAbsoluteUri'] directive empty. See also FAQ 4.7.
* Maybe you have a broken PHP installation or you need to upgrade your Zend Optimizer. See bug.php?id=31134.
* If you are using Hardened PHP with the ini directive varfilter.max_request_variables set to the default (200) or another low value, you could get this error if your table has a high number of columns. Adjust this setting accordingly. (Thanks to Klaus Dorninger for the hint).
* In the php.ini directive arg_separator.input, a value of ";" will cause this error. Replace it with "&;".
* If you are using Hardened-PHP, you might want to increase request limits.
* The directory specified in the php.ini directive session.save_path does not exist or is read-only.


So bottom line I don't think the upgrade went well and could use some advice.

I do have a backup of the DB prior to startiing this if I need to restore it.

Your help is appreciated.

John

Sign in to reply to this post

12.bernie410015

Disregare previous post

Please disregard the previous post. I got the first script to work. Still have issues with second script but working on it.
John

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...