close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

ie8 problem but not always?

Thread began 10/13/2010 11:41 am by roy.chappell355352 | Last modified 10/14/2010 9:50 pm by neilo | 908 views | 4 replies |

roy.chappell355352

ie8 problem but not always?

Hi

I created a site some time ago ~ food.htm ~ recently the client says it is not displaying correctly, she is using ie8. I have had a look at the site in my version of ie8 but dont see the problem. She reports a few people are seeing the error with ie8 yet i have got others to look at it with ie8 and they dont see the problem ~ its very strange.

This is a link to an image of the problem area they have ~ food-page.jpg

Thanks for any help, its driving me mad mainly as i cant see the problem to correct.

Roy

Sign in to reply to this post

neilo

The clients who are seeing the error are viewing the page in IE8 'compatibility view', a feature to render older pages correctly.

They should just switch compatibility view off.

Sign in to reply to this post

neilo

Something else to try might be to add a clearing element before the closing </div> tag of the #content div.

Find the code in your page:

<p>Sara Hester &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Sevenoaks &nbsp;&nbsp;01732 460350<br>
Carole Wildman &nbsp;Godalming &nbsp;01483 427329</p>
</div>
<!-- InstanceEndEditable --> </div>

and try adding:

<br style="clear: both; height: 0pt; font-size: 1px; line-height: 0px;">

just before the closing div tag (just before the '<!-- InstanceEndEditable --> comment):

<p>Sara Hester &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Sevenoaks &nbsp;&nbsp;01732 460350<br>
Carole Wildman &nbsp;Godalming &nbsp;01483 427329</p>
</div><br style="clear: both; height: 0pt; font-size: 1px; line-height: 0px;">
<!-- InstanceEndEditable --> </div>

That should force the 'content' div to fully contain the copyholder div, and present OK whether IE8 is in compatibility view or not. Maybe. It's worth a try.

Sign in to reply to this post

roy.chappell355352

thanks & a solution

Hi

Thanks for your comments.

Unfortunately adding
<br style="clear: both; height: 0pt; font-size: 1px; line-height: 0px;">
had no effect.

I got around the problem by adding the following code just below <head>, just below <head> is important for it to work

<meta http-equiv="X-UA-Compatible" content="IE=ie8" />

This enforces IE8 to display the page in the IE8 Standards Mode engine

Roy

Sign in to reply to this post

neilo

Many thanks for posting back with the tip, Roy.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...