close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

authorize.net (linkpoint) going live

Thread began 9/29/2010 1:29 am by CraigR | Last modified 9/30/2010 6:33 pm by Jason Byrnes | 1558 views | 16 replies |

CraigRBeta Tester

linkpoint going live

I have a client with PS3 who is struggling to go live.

He has attempted to get linkpoint (first data) working, but always gets a transaction failure.
he has the pem file in the linkpoint folder on the root and set the global settings to use gateway 2 as there is no option for linkpoint, 2 sets the gateway to be authorize.net

from what i understand, if the gateway is set to 0, (no gateway), then the C/C form is not displayed

there is an eCart local checkout server behavior on the confirm.php page with. it seems, all relevant details.

i have pasted the appropriate checkout response bindings into checkout_failure, but when i check local checkout response errors, i get nothing.

SO, i added Full Request and Full response to my checkout failure page, get a load of text, which implies the transaction is good, but i get transaction failure.

can someone please walk me through what to check.

(i also just noticed that in the wa_settings table, there is no data for login or transaction key for gateway 2 (lines 34 & 35), which i assume is for authorize.net only so assume this isn't a factor ?)

here is my binding, (edited) and presented in an easy to read format..

<order>
<merchantinfo>
<configfile>0000000000</configfile>
<keyfile></keyfile>
<host>https://secure.linkpt.net/lpcentral/servlet/lppay</host>
<port>1129</port>
</merchantinfo>
<orderoptions>
<ordertype>SALE</ordertype>
<result>GOOD</result>
</orderoptions>
<payment>
<tax>0</tax>
<shipping>7.95</shipping>
<subtotal>4.99</subtotal>
<chargetotal>12.94</chargetotal>
</payment>
<billing>
<name>Name</name>
<address1>Address1</address1>
<address2>Address2</address2>
<city>City</city>
<state>N/A</state>
<zip>ZIP</zip>
<country>GB</country>
<phone>12345 67890</phone>
<fax></fax>
<email>mail@mail.com</email>
</billing>
<creditcard>
<cardnumber>1111111111111111</cardnumber>
<cardexpmonth>12</cardexpmonth>
<cardexpyear>2011</cardexpyear>
<cvmvalue>765</cvmvalue>
</creditcard>
<shipping>
<name>Name</name>
<address1>Address1</address1>
<address2>Address2</address2>
<city>City</city>
<state>N/A</state>
<zip>ZIP</zip>
<country>GB</country>
<items>1</items>
<weight>0.1</weight>
<total>4.99</total>
</shipping>
<transactiondetails>
<taxexempt>N</taxexempt>
<terminaltype>UNSPECIFIED</terminaltype>
<oid>q3vnqq639205hutfleiegjelo7</oid>
</transactiondetails>
<items>
<item>
<id>73</id>
<description>Product Description</description>
<price>4.99</price>
<quantity>1</quantity>
</item>
</items>
</order>

thanks

Sign in to reply to this post

Jason ByrnesWebAssist

the heart of the issue is that it is not finding the key file:

<keyfile></keyfile>


the code to find the key file will look similar to:

php:
$LinkPointAPI_required[0][$nextIndex] = "merchantinfo->keyfile";

  $LinkPointAPI_required[1][$nextIndex] = "".realpath("../linkpoint/test.pem")  ."";




the real path command should return a OS path to the file similar to:
/Applications/MAMP/htdocs/linkpoint/test.pem

in some cases, i have seen issue if the path contains /n or /t being interpreted as a new line or tab

So it may see:
/test.pem

and interpret that as "{tab}est.pem" (i put tab in {} for demonstration sake.)


if this is the case, you can get around the issue by hard coding the path to the pem file:

php:
$LinkPointAPI_required[0][$nextIndex] = "merchantinfo->keyfile";

  $LinkPointAPI_required[1][$nextIndex] = "/Applications/MAMP/htdocs/linkpoint/test.pem";
Sign in to reply to this post

CraigRBeta Tester

Hmm.

well the pem file is definitely there, and the path is as you suggested it would be.

i don't want to hardcode it, as it won't work when the files move from the testing server.

i tried echoing the line on the checkout page like so...

echo 'path is'."".realpath("../linkpoint/number.pem") ."";

but it returns nothing.

do i need to use realpath at all or can i use a relative path ?

Sign in to reply to this post

Jason ByrnesWebAssist

it has to be the full OS path, not a relative path.

where is the pem file located in relation to the confirm page?

your code:
realpath("../linkpoint/number.pem")

is moving down one directory from the confirm page to look for the linkpoint folder. is this correct?

what if you use:

<?php echo("Confirm Path: ".realpath("confirm.php").""); ?>

what does that return?

Sign in to reply to this post

CraigRBeta Tester

thanks Jason, little light bulb suggests path was keyed in looking at an example, and the pem file is in the linkpoint folder in the root, same as the confirm page.

So, now the pem file is being retrieved correctly, the transaction still fails, but the <keyfile></keyfile> tags now contain a value, which is the correct path to the pem file.

**Just a thought, this is my clients pem, will it actually work on my testing site ??**

Sign in to reply to this post

Jason ByrnesWebAssist

it should work from your testing site.

do you still not get any full response back? still only the full request?

Sign in to reply to this post

CraigRBeta Tester

no response at all, just the request

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

Sign in to reply to this post

CraigRBeta Tester

Thanks Jason.. 99% there

Many thanks for the call yesterday Jason.

Just to confirm the changes made if anyone else wishes to go along the linkpoint route, (don't)..

Ensure the .pen file path is correct
Change the url to $LinkPointAPI_required[1][$nextIndex] = "secure.linkpt.net";
set the expiry year for c/c to 2 digits instead of 4, and alter the validations accordingly
ensure the trigger to populate the linkpoint array is on the 'submit order' button being pressed, and NOT any form post.

Now here's the problem I still have.

I uploaded the files to my testing server, and everything works perfectly, as it did last night.;)

I then uploaded the same files to my client's server, and I get transaction failed again.
It seems to take a very long time to decide not to connect, so it may well be a timeout issue ??
(If i put in a url that i know is incorrect, it fails pretty much instantly)

I know this doesn't make sense, but there you are.

I consulted the linkpoint manual, and the url it provides is different, so I also tried this and some variations, but no success.

I added the local checkout response codes to checkout_failure, and again, the full request is shown, but no response.

( i get the error, regardless of whether the site is in 'test' mode), as defined in the first tab of the admin settings page

I am struggling for ideas

Sign in to reply to this post

johnb

Subscribing... Interested in the outcome of this

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...