close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Security Assist Bug?

Thread began 9/28/2010 12:15 am by twitchr377598 | Last modified 10/07/2010 10:55 am by Jason Byrnes | 1160 views | 8 replies |

twitchr377598

Security Assist Bug?

Hello Webassist gurus,

I used security assist to add a registration and log in page to my site. I am wanting to add a session variable to my existing authenticate user server behavior. I open up the authentic user behavior in the wizard and page over to step 3 where you can add or delete session variables. I click the plus button and a list of my columns shows up in a menu, I choose one and nothing happens. It doesn't let me add a session variable here. Any thoughts?
I'm using CS5 and Security Assist version 1.1.9.

In the meantime, where do I add a new session variable in the code by hand? I currently have a session called memberID from the memberID column in my members table. I want to make a session called memberStatus from the memberStatus column in my members table upon log in as well.

<?php
if(isset($_POST["LogIn"])){
$WA_Auth_Parameter = array(
"connection" => $mydatabase,
"database" => $database_mydatabase,
"tableName" => "members",
"columns" => explode($WA_Auth_Separator,"memberEmail".$WA_Auth_Separator."memberPassword"),
"columnValues" => explode($WA_Auth_Separator,"".((isset($_POST["username"]))?$_POST["username"]:"") ."".$WA_Auth_Separator."".WA_SHA1Encryption(((isset($_POST["userpassword"]))?$_POST["userpassword"]:"")) .""),
"columnTypes" => explode($WA_Auth_Separator,"text".$WA_Auth_Separator."text"),
"sessionColumns" => explode($WA_Auth_Separator,"memberID"),
"sessionNames" => explode($WA_Auth_Separator,"memberID"),
"successRedirect" => "index.php",
"failRedirect" => "email_pw.php",
"gotoPreviousURL" => TRUE,
"keepQueryString" => TRUE
);

WA_AuthenticateUser($WA_Auth_Parameter);
}?>

Thanks in advance,
Twitch

Sign in to reply to this post

Jason ByrnesWebAssist

I'm trying to reproduce the problem, but am not able to. The Selected column is being added to the session variables list.

perhaps try deleting the Dreamweaver cache file from the users configuration folder:
common_installation_issues.pdf



in the mean time, you can manually edit the code.
change:

php:
"sessionColumns" => explode($WA_Auth_Separator,"memberID"),

"sessionNames" => explode($WA_Auth_Separator,"memberID"),





to:

php:
"sessionColumns" => explode($WA_Auth_Separator,"memberID".$WA_Auth_Separator."memberStatus"),

"sessionNames" => explode($WA_Auth_Separator,"memberID".$WA_Auth_Separator."memberStatus"),
Sign in to reply to this post

twitchr377598

Thanks for the quick reply, Jason. I was using $WA_Auth_Separator, instead of .$WA_Auth_Separator. when editing by hand. I'll give that a try shortly. As for the bug, I may end up wiping my machine and starting from scratch. I've had various other issues. Maybe it's not the extension. I'll keep you posted. I've just had too much work to have my computer down for any length of time to redo it...haha A good problem to have I guess.

Thanks again,
Twitch

Sign in to reply to this post

Jason ByrnesWebAssist

instead of reinstalling the entire system, you may want to try deleting the configuration folder and reinstalling the extensions.

The common installation issues technote will help you locate the configuration folder.

Close Dreamweaver and the Extension manager, then you can delete the configuration folder and re open the extension manager. This will disable all of the extensions. from here, you should uninstall each one, then download the latest mxp files and reinstall them.

Sign in to reply to this post

twitchr377598

Thanks Jason, I know the configuration folder well unfortunately...haha That said, editing manually did the trick.

While on the subject of logging in, is there a way to have an authenticate user behavior look at 2 different tables for logging in, ie: verify the username and password exists from either a table called 'users' or table called 'admin'?

Did a quick search of this forum but didn't see anything similar.

Thanks in advance!

Sign in to reply to this post

Jason ByrnesWebAssist

No, not really.

The closest would be to have two authenticate user behaviors on the page, one for each users table.

You would also need to have separate login forms.



you would be better combining users and admins into one table and using User Level Authentication.

The solution recipes section of the Security Assist support page talks about this.

Sign in to reply to this post

Steve

I have the same problem...

Happens on the second page as well. When you try to add a field it does nothing. Click try again, again, again etc etc eventually it works. But it only works for adding one field.. Close and open try again and again then eventually you'll get to add your second column (such as password). Then off to page three... Same problem, select to add, chose an available value to use as a session then it never completes...

CS5 latest stuff, 10 gigs of Ram, etc etc.. Yes' I'll now try removing the dat file

Sign in to reply to this post

Steve

Removed dat files and even restarted the putter..
Got one session value to take now back to being useless. No new values will "take'....

very disappointing.

This stuff only tested on a PC?

Sign in to reply to this post

Jason ByrnesWebAssist

You have an open support incident for another issue, we will look into this issue with you on the phone at the same time as the other.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...