close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

URL Parameter isn't pulling content...

Thread began 8/25/2010 1:50 am by blackweldermhe400113 | Last modified 8/26/2010 12:51 pm by Jason Byrnes | 1048 views | 7 replies |

blackweldermhe400113

URL Parameter isn't pulling content...

I'm having a strange problem occur on the details page for my greeting cards section. I have a page that is for greeting cards. This page lists all cards in descending order, but you can also filter the card selection by the occasion. The card entry has a "Find Out More" button that loads the selection with detailed information to a greetingCards_Detail.php page through a URL Parameter of the product ID. Locally this works fine. You make a selection on the greetingCards.php and it passes to the greetingCards_Detail.php page with no errors. When I upload it live, there is no information passing to the details page. The page isn't blank, but the content areas where the recordset bindings are supposed to be loading the information are blank. I'm completely stumped. Can anyone help? Attached are the greetingCards and greetingCards_Detail pages, and I will also provide you with the link to the live page.

greetingCards.php

Attached Files
greetingCards.zip
Sign in to reply to this post

Dave BuchholzBeta Tester

1st place to start would be your database connection, ensure that the non working page has the correct database connection details.

Sign in to reply to this post

Jason ByrnesWebAssist

also check your other tables.


the product recordset on the details page uses inner joins for the testament, category and occasion tables.

the nature of an inner join is that no result will be retuned if a match cannot be made in all joined tables.

Sign in to reply to this post

blackweldermhe400113

Checked both suggestions and still not working.

I double checked the database connection, and it's fine on that page. I know this because part of my navigation is being pulled from the database. Also, I removed the INNER JOIN that wasn't needed and the binding are still appearing blank on the live site. I just think that it is odd that the page works fine locally but not live. Any other suggestions?

Sign in to reply to this post

blackweldermhe400113

Correction... Just figured it out.

Thanks Jason and Dave for your suggestions.

Sign in to reply to this post

Jason ByrnesWebAssist

Glad to hear you have it figured out, just out of curiosity, what was the issue?

Sign in to reply to this post

blackweldermhe400113

The problem...

I have a category ID that I'm using to identify what type of product that the item is. I was still including this as an INNER JOIN in the products recordset on my detail page, but it wasn't needed because I was filtering from the greeting cards page by the product ID. So, you were right, the unused INNER JOIN was causing the issue. Thanks for your input.

James

Sign in to reply to this post

Jason ByrnesWebAssist

Got ya, thanks for posting back.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...