close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Emails Not Sending

Thread began 7/12/2010 6:41 pm by rdubill357341 | Last modified 7/16/2010 2:21 pm by Eric Mittman | 830 views | 5 replies |

rdubill357341

Emails Not Sending

I have set up a registration page using Security Assist that requests an e-mail address in a form.

It updates the database just fine.

I added Universal Email to that page to send the registration information to both the customer and myself.

When I register as a user I receive no error messages, the database updates OK, but no e-mail is sent/received.

Using ASP.

Using CDOSYS email object (which I know my host supports since I use that for another site hosted by the same company - also using Universal Email for that site with no problems.)

Tried triggers 'register button', 'any form post', and 'current page submit' - same result.

Suggestions?

thanks!

Sign in to reply to this post

Eric Mittman

How do you have the Universal Email server behaviors configured on the other pages on your server that are working? If you have other pages that work with the UE code then this one should as well so long as it is configured the same. If you have more trouble with this please post back with the current page that has the Universal Email server behavior on it, another page from you site with the server behavior that is working, and a copy of the WA_UniversalEmail folder from your site root in a zip archive. I will take a look to see what differences I can spot.

Sign in to reply to this post

rdubill357341

Email not Sending

Eric - I have attached a zip file for your review.

The file contains:

- the Universal email folder for the site that does not work
- the file Webusers_Registration.asp - page that does not send emails
- the file confirm.asp - the file from another site that does work sending emails


thank you!
Bob

Attached Files
Universal Email Problem.zip
Sign in to reply to this post

Eric Mittman

Do you know if the page that is working correctly is on the same server? I'm curious what happens if you were to switch these working and non working versions. On the site that has this working make a backup of the page and the Universal Email folder, then add in a page that has just the UE server behavior on it from the page that is not working, also make sure to use the non working Universal Email folder on this site. Test this out to see if the non working one begins to work.

You can also test this in reverse by backing up all of the non working sites parts and replacing them with the working versions. When you test this out it should help to determine if the problem is one that is specific to the site, or just the pages that are involved. Along with this info please also post back with a copy of the email folder from the site that is working.

Sign in to reply to this post

rdubill357341

Emails not Sending

Eric - thanks for your efforts...

All fixed!

Changed the redirect to be on the Universal Email behavior instead of the Security Assist insert record behavior - that did it!

Bob

Sign in to reply to this post

Eric Mittman

Glad to hear that, let us know if you have any other questions.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...