close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

localhost with Dreamweaver CS3

Thread began 6/17/2010 4:08 pm by joe405450 | Last modified 6/30/2010 8:20 pm by Eric Mittman | 5247 views | 6 replies |

joe405450

localhost with Dreamweaver CS3

I started using Dreamweaver CS3 in December 2009, and love it. I developed a website for my lodge over the last 6 months, much of it static. I am undertaking the addition of e-cart and dynamic pages with PHP using Webassist products. My issue is with localhost. Below are current set-ups:

operating sys: windows XP pro

software: dreamweaver CS3; Xammp

Local Root folder: C:\Documents and Settings\Admin\Desktop\new_Hills_25_site\

Http address: www.hillsborough25.org/

Remote host / directory: hillsborough25.startlogic.com/public_html/

Testing server folder: C:\Documents and Settings\Admin\Desktop\new_Hills_25_site\

URL prefix: webtest

I have verified that PHP is running on my computer, and have been able to build databases and tables. I cannot get dreamweaver to connect!!! I've spent 2 days trying to figure this out, and did not want to have to rebuild entire site.

I keep getting HTTP 404 errors from dreamweaver.

Please help me

Sign in to reply to this post

Eric Mittman

What is the exact error you are getting when you try to connect? I have seen before where 404 errors occur for the _mmServerScripts directory. These files should hold information about your site and connection. If they are bad in any way you can have problems like this. I would suggest duplicating the DW site, then deleting the _mmServerScripts folder along with the connection folder and try creating a new connection.

Sign in to reply to this post

joe405450

Ok..I tried removing the mmServerScripts folder, relocating the entire site to the directory where the localhost is located, and retried the connection with the following settings:

MySQL server: xampp/
User Name: root
Password: xxxxxxxxxx
Database: hills25_data

The error message I get is the same -

Http Error Code 404 File Not Found. Here are some possible reasons for the problem:

1) There is no testing server running on the server machine
2) The testing server specified for this site does not map to the MMHTTPDB.php URL. Verify that the URL Prefix maps to the root of the site.


As a point of information, below is the mapping for the site definition:

Local root folder: C:\xampp\htdocs\test_hills25\
Default images folder: C:\xampp\htdocs\test_hills25\images\
HTTP address: test_hills25/
Testing server folder: C:\xampp\htdocs\test_hills25\
URL Prefix: test_hills25/

I cannot believe that this operation can be this difficult. I purchase Security Assist, Data Assist, E-Cart, and Universal Email to help make programming much more efficient. So far, the only one that hasn't given me any trouble is Universal Email.

Please help with this, as I am running very close to deadline on my project.

Joseph

Sign in to reply to this post

Eric Mittman

The error you are getting is not from any of our extensions, it is coming from Dreamweaver. It is telling you that there is a problem with the way that the testing server is setup. The message is saying that the script file cannot be found in the location it is looking for it. This is one of Dreamweavers internal resources that are used to manage your site. The file and location it is looking for is:

MMHTTPDB.php

Based on your site settings it looks like your testing server URL is wrong, if the web root for xamp is located in C:\xampp\htdocs\ then the URL for the testing server should be like this:

test_hills25/

The localhost will map to the root of the web server so you should not list the folders that come before this.

Sign in to reply to this post

joe405450

THANK YOU SO MUCH!!! I was able to connect by changing the URL and removing the additional folders. You've been a great help; have a GREAT day!

Joseph

Sign in to reply to this post

joe405450

security assist error

Eric,

I've managed to get all pages working on my localhost, created and connected to a database, worked through and installed Data Assist. I put Security Assist on as well for security of Admin, and all pages for Security Assist work fine, expect for a few pages using Data Assist (these were working before). Here is the errors I get when trying to search a database, or follow a link from the admin main menu:

Warning: require_once(../../WA_SecurityAssist/Helper_PHP.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\test_hills25\webassist\email\mail_php.php on line 1

Fatal error: require_once() [function.require]: Failed opening required '../../WA_SecurityAssist/Helper_PHP.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\test_hills25\webassist\email\mail_php.php on line 1

Any ideas on how to fix this?

Thanks,

Joseph

Sign in to reply to this post

Eric Mittman

The error you are getting now is telling you that the include files cannot be found in the location specified in the link. Rite now it is looking for the files here:

../../WA_SecurityAssist/Helper_PHP.php

Based on the location of the file that is giving you this error:

C:\xampp\htdocs\test_hills25\webassist\email\mail_ php.php

It would be looking for this file in

C:\xampp\htdocs\test_hills25\WA_SecurityAssist\Helper_PHP.php

Do you have these files in this location? If you find these files in your site and make sure they are in this location you should not get these errors.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...