close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

File Manager not displaying correctly

Thread began 6/16/2010 6:42 pm by gstoyle396649 | Last modified 6/24/2010 10:38 am by Eric Mittman | 1837 views | 13 replies |

gstoyle396649

File Manager not displaying correctly

I've used HTMLEditor on a number of sites but never encountered this problem.

On the server, when I click Browse Server to view the file manager it doesn't display correctly (screenshot attached).

It works fine locally. All permissions on the server are set to 777.

Any ideas/solutions greatly appreciated.

Thanks.

Sign in to reply to this post

Eric Mittman

Do you have error reporting turned on for the live server? It seems that there might be an error occurring somewhere that is not being displayed. If you don't have access to the php.ini file then you can add in the following code to the top of your page to allow for error reporting:

php:
<?php 

error_reporting
(E_ALL); 
ini_set('display_errors','on'); 
?>



When you configured this locally did you specify upload locations that are present on the live server?

Sign in to reply to this post

gstoyle396649

Thanks for the reply Eric.

I tried your suggestion but unfortunately don't get an error.

The upload location is present on the live server and permissions have been set.

Strangely, it doesn't seem to be affecting uploads, but when I do upload an image it is only displayed as a hyperlink (another screenshot attached) and none of the other functions of the file manager are there.

As I said I've used this a number of times with no problems - I think this must be server-related, but I can't think what?

Any more suggestions would be appreciated.

Thanks again.

Sign in to reply to this post

Eric Mittman

We will need to look into this issue further to determine what is going on. I have opened a ticket for you so we can exchange some details in private. To update the ticket or check on it's status login and visit your support history.

supporthistory.php

Sign in to reply to this post

neilo

Hi Eric,

Probably entirely unrelated, but with my set-up (on certain servers) it was a problem with the 'HTMLEditor/editor/plugins/kfm/.htaccess' file that was causing the problem. Renaming the .htacess file solved my problem.

Sign in to reply to this post

gstoyle396649

Originally Said By: neilo
  Hi Eric,

Probably entirely unrelated, but with my set-up (on certain servers) it was a problem with the 'HTMLEditor/editor/plugins/kfm/.htaccess' file that was causing the problem. Renaming the .htacess file solved my problem.  



Thanks for the suggestion - I tried it, but unfortunately this time I just get a blank window with "Please wait...loading".

The fact that renaming htaccess had some effect makes me think it must be related, but I can't think how (?)

One thing I have noticed is the URL in the file manager window that doesn't work is...

/HTMLEditor/editor/filemanager/browser/default/browser.php?Type=Image&Connector=http://ecologicalphotography.co.uk/HTMLEditor/editor/filemanager/connectors/php/connector.php

...whereas on a file manager that does work (on another server) this URL is...

/HTMLEditor/editor/plugins/kfm/index.php?lang=default&kfm_caller_type=fck&type=Image

Sign in to reply to this post

neilo

Hi there,

Yes - when I add the 'doesn't work' url string you posted in the address bar after my own url/HTMLEditor/directory path, I get the old standard type kfm file browser that you are currently getting. That is the same url that my editor defaults to if I leave the htaccess file entirely intact.

People on other threads have reported solving the problem by deleting just the 'php_value magic_quotes_gpc off' lines under the 'mod_php4c' & 'mod_php4c' lines.

Could you post a link to the javascript file in your HTMLEditor/custom folder (if there are more than one then the one with the highest number at the end)?

All academic as Eric will sort it in a flash, but just curious!

Sign in to reply to this post

gstoyle396649

Originally Said By: neilo
  Hi there,

Yes - when I add the 'doesn't work' url string you posted in the address bar after my own url/HTMLEditor/directory path, I get the old standard type kfm file browser that you are currently getting. That is the same url that my editor defaults to if I leave the htaccess file entirely intact.

People on other threads have reported solving the problem by deleting just the 'php_value magic_quotes_gpc off' lines under the 'mod_php4c' & 'mod_php4c' lines.

Could you post a link to the javascript file in your HTMLEditor/custom folder (if there are more than one then the one with the highest number at the end)?

All academic as Eric will sort it in a flash, but just curious!  



Thanks Neilo - I tried removing those lines in the htaccess...no joy I'm afraid.

The link to the javascript file is index_homeContent2.js

Thanks again.

Sign in to reply to this post

gstoyle396649

Further to the above - I've uploaded another site to the same server and have got the same problem. I have no idea how to resolve this and don't think the host will be very helpful - has anyone got any other suggestions. Otherwise I'll probably have to change hosts...or try a different HTML Editor.

Many thanks

Sign in to reply to this post

neilo

Hiya,

Did you update the ticket Eric created for you (see post #4 above)?

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...