close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Universal Email 4 not sending emails

Thread began 5/21/2010 8:13 pm by ken263213 | Last modified 6/08/2010 1:33 pm by Jason Byrnes | 2577 views | 16 replies |

ken_shaw263213

Universal Email 4 not sending emails

I just bought UE4 to work with a form designed with CSS Form Builder.
The form appears to be validating OK but nothing gets to my email.
Thought this would be a straight forward turnkey solution.

How do you edit an existing UE4 functioning form on a page?

Possibly the SMTP server needs password authentication but there appears to be NO way to bring back UE4 to edit and there is nothing about that in the documentation.

I do not want to publish the site publicly right now as it is still in development and I need to get this problem fixed.

Sign in to reply to this post

dave403891

Had a similar problem. Seems that I either needed to install a localhost email server or take the site to the remote server and run it through the host's STMP.

Sign in to reply to this post

Jason ByrnesWebAssist

To edit an existing Universal Email instance, open the Server behaviors panel. Window -> Server Behaviors. In the Server Behaviors list, double click the universal Email server behavior.


If you are testing on your local computer, you will need to have an SMTP server installed.


It is better to test Universal Email on the production server using their SMTP server.

success with universal Email is dependent on a few factors:
1) Using the correct email object. Universal Email has support for the PHP Mail object and PEAR mail using SMTP.

The PEAR Mail option will allow you to pass authentication credentials to the SMTP server. you should contact your host to determine which one they will support.

2) Make sure to use the proper SMTP server address.

3) A proper;y formatted form. The form should be set to use the POST method and to POST to itself.

4) Do not use the same address in the To section as is used in the From section.

This will cause the email to be treated as spam.

Sign in to reply to this post

ken263213

UEM4 Not sending emails

I am staging the site on sub-domain of my hosted site so has a working email server.
Answers to questions 1 - 4...
1. Checking into that with hosting service.
2. yes
3. set to POST and to itself.
4. they are different

Sign in to reply to this post

Jason ByrnesWebAssist

  1. Checking into that with hosting service.  



once you have universal email set to use the supported mail object please post back your results.

Sign in to reply to this post

ken263213

UE4 not working

So... How do I get the UE4 wizard to edit the existing email configuration on the page to change it? So far all I can find is the PHP file and I don't know the syntax to use for the various parameters.

Sign in to reply to this post

Jason ByrnesWebAssist

to edit an existing Universal Email instance, open the Server Behaviors panel:
Window -> Server Behaviors

In the list of server behaviors, double click the Universal Email behavior to edit it.

Sign in to reply to this post

ken263213

UE4 not working

Here is reply from hosting support...
here is original reply from plugin developer...

1) Use the correct email object. Universal Email has support for the PHP Mail object and PEAR mail using SMTP.

The PEAR Mail option will allow you to pass authentication credentials to the SMTP server. you should contact your host to determine which one they will support.


Use:
server name: localhost
with a valid email address/password to login to an account on the server.

You need to use SMTP auth if you are sending via an library that communicates via SMTP.

If not, using sendmail command directly is a more reliable way.

That should answer their question.

******************

I can not discern how to take that information and work with it in UE4.
In server behaviors, there is no UE4 behavior listed.

Sign in to reply to this post

ken263213

UE4 not working

additionally, I can not find a reference to PEAR on my hosting service so I do not know what to do with that, especially the UE4 UI that asks for the path to PEAR.

Sign in to reply to this post

Jason ByrnesWebAssist

quote:
Use:
server name: localhost
with a valid email address/password to login to an account on the server.


so it sounds like you need to configure an email account on the SMTP server, it sounds like the email address for that account should be used for the username, and the password you use to log into that account should be used for the password.

As far as the path to pear goes, only the host can tell you what the path to use is.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...