close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Email not being sent from UE4

Thread began 5/19/2010 12:25 pm by dave403891 | Last modified 5/20/2010 8:57 am by dave403891 | 972 views | 10 replies |

dave403891

Email not being sent from UE4

Using CS4.

First time using UE. After completing quick insert using block design for an email response to a new subscriber welcoming them to the site community, no email is sent. Wondering if the problem has to do with the trigger. Tried using default "any form post", then tried using "current page submit", and finally tried "Recordset: rsSubscribers is not empty". Nothing works. This should be simple, but I'm stumped.

Sign in to reply to this post

Jason ByrnesWebAssist

Did you set a Go to page to be redirected to after the email is sent?

If so, are you redirected to that page?

What is the action of the form on your page? It should be left blank so the form will post to itself.

What is the method of the form? It should be set to POST

If all of those check out, then double check the SMTP server that you entered, make sure it is the correct one for your host.

try checking the "Include From Address as an additional parameter" option. your host may require this.

Make sure that the From address and the too address are not the same, some hosts will not relay email messages where the from and too addresses are the same.

If you getting redirected and still not seeing the message, you will need to check with the host, see if they can look into the SMTP server error logs to why the email message is not being relayed.

Sign in to reply to this post

dave403891

Jason,

Left "Go to page" blank because the visitor is taken to a thank you page when they hit the submit button.

Form action is "<?php echo $editFormAction; ?>". I'll delete this.

The method is Post.

I'll try again.

I'm doing all this on my local site with MAMP

Sign in to reply to this post

Jason ByrnesWebAssist

how are they being taken to the thank you page? in another server behavior?

Usually Universal Email is added as the lat server behavior on the page. If another server behavior is redirecting to the thank you page, this will happen before universal email has a chance to execute. If there is another server behavior sending to the thank you page, remove that redirect and set Universal Email to perform the redirect.

Sign in to reply to this post

dave403891

Jason,

Thanks for sticking with me.

UE behavior was the last added, but I moved the go to to the UE behavior and removed it from the insert form behavior.

Tried again. I was redirected to the proper page but did not receive the email.

I checked the email log and it reports email status as success, but it has the following listed under EmailError - Sending to: dave@davecowan.com... Success </br>

I'm puzzled.

Sign in to reply to this post

Jason ByrnesWebAssist

the email log can only really tell you that the email was sent to the smtp server successfully.

If the email is being sent to the SMTP server, there are really only two possibilities:
1) The email is being trapped in a spam filter

2) The SMTP server is refusing to relay the message.

If you do not see the email in your spam filter, you will need to check with the host to have them look into the SMTO server error logs to determine why the server is not relaying the message.

Sign in to reply to this post

dave403891

Jason,

Does it matter that I'm using a localhost?

Sign in to reply to this post

Jason ByrnesWebAssist

Do you have an SMTP server set up on your local computer?



you will need an SMTP server set up and configured on your local computer if you are using localhost.

Sign in to reply to this post

dave403891

I use an ISP and its server. How do I set up a server on my Mac with OSX. This is new territory for me.

Thanks again for your support!

Sign in to reply to this post

Jason ByrnesWebAssist

setting up an smtp server is not a simple task, and not something I can offer support for.

you should upload your files to the server to test your hosts SMTP server.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...