close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Enable Write Permissions on Directory (PowerCMS 2)

Thread began 5/14/2010 1:28 am by light_ndubuizu407087 | Last modified 5/17/2010 2:57 pm by Jason Byrnes | 2391 views | 7 replies |

light_ndubuizu407087

Enable Write Permissions on Directory (PowerCMS 2)

Hi,

I am about to configure PowerCMS 2 on my local computer before uploading it, but it get to a point and it shows me this: ERROR: All of the attributes below need to check out before you can proceed to the next step.

How do i enable permissions to the PowerCMS file folder? I'm using Windows 7 with IIS7.

Thanks in advance.

Sign in to reply to this post

Jason ByrnesWebAssist

If you have Dreamweaver, it can be done in the Dreamweaver files panel.

In the files panel, change the view to Testing Server.

Locate the files folder , right click it and select Set Permissions.

Set the permissions to allow Read and Write access for all three users.

Sign in to reply to this post

light_ndubuizu407087

That worked. Another problem.

Thanks. it worked but i'm stuck again. I want to run PowerCMS on my local computer before uploading it. I use IIS7.5. When installing i get to the page it asks for my database information. I put in all the information.:

Server/Hostname: localhost
Database: databasename
Username: username
Password: *******

When i put all that in, it tries loading for like 30 seconds and then shows me an error page with the error:

HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.

I've tried re-installing php, tried re-installing mysql, tried re-downloading PowerCMS, but nothing. What do i do? I have to begin this project and fast. Thanks for your help in advance.

Sign in to reply to this post

Jason ByrnesWebAssist

the 500 error is a very generic error that literally means "An error occurred". It is a generaic error that will show if the system has been set not to send errors to the screen.

to be able to tell whats wrong, we need to know the real error.

To enable the more advanced error messaging in IIS 7 for Vista you will need to do the following:

1) Go to Control Panel > Administrative Tools
2) Open the IIS control panel and open the ASP option
3) At the top of the ASP control area select Display: Friendly Names
4) Now go down to the Compilation area and expand Debugging Properties
5) In debugging properties make sure to set Enable Client -side Debugging, Enable Server -side debugging, and Send Errors to Browser to TRUE. Make sure to click the Apply on the right side of the page.
6) After setting the debugging you must go back to the IIS control panel and using the controls on the right side restart the server.

This will enable debugging info to display when an error occurs. This should be turned on while testing and should not be left enabled for a live server.

Also, try using FireFox instead of IE.

Sign in to reply to this post

light_ndubuizu407087

I've done that, still the same thing. Under the detailed error information, it shows this:

Module: CgiModule
Notification: ExecuteRequestHandler
Handler: PHP
Error Code: 0x00000000

So what do i do?

Sign in to reply to this post

Jason ByrnesWebAssist

To be honest, I have never had luck getting PHP / MySQL Working correctly under IIS7.

After spending 3 weeks, I ended up uninstalling IIS, undoing all the changes I made to install PHP, uninstalling MySQL and installing XAMPP instead.

From download to working php testing server took me 8 minutes.
xampp_for_windows.php

Sign in to reply to this post

light_ndubuizu407087

Another Problem Again

Hi, i got that working. But another problem.

I am now on step 3 of configuring PowerCMS. I am asked to input my admin info. I do that but then i get another error: ERROR: Failed to save the settings in the database. Please verify your database connection.

Helpppp! What do i do now. I'm really getting tired of this. I just bought both Super Suite & Solution Suite- i hope i dont have to go through this for all of them. :(

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
login.php

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...