close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

JS Error When Trying to Use Extension

Thread began 5/12/2010 2:14 pm by admin140217 | Last modified 5/19/2010 8:31 pm by admin140217 | 1948 views | 12 replies |

admin140217

JS Error When Trying to Use Extension

I'm getting an error message when I stry to start SiteImport, the following message comes up when I press go:

While executing onClick in WA_SiteTools_Progress.htm, the following Javascript error(s) occurred:

In file "WA_SiteTools_Progress":
ImportNew is not defined

This repeats every time I try to execute a site import.

How do I solve this?

Thanks

Sign in to reply to this post

admin140217

I should add

that I have tried the common fixes as described in the PDF. I am using DWCS4 on Vista Ultimate

Sign in to reply to this post

Eric Mittman

Have you tried renaming the config folder and re-install the extension? Here are the steps you can take for this:

showpost.php?p=12293&postcount=2

If you have already done this or get the same result after trying let us know and I will ensure that a ticket is opened for you so we can look into this more.

Sign in to reply to this post

admin140217

I have not renamed the configuration folder Eric and would rather not, I have a lot of extensions and not all from WebAssist, renaming the folder would affect all of the extensions installed.

Isn't there another way, quite honestly the extension should work without having to rename the configuration folder in the program it's being used in.

Is this something that is specific to WebAssist products and their Javascripts? If I unistall all the WebAssist products and re-install them, would that help the issue?

Thanks

Sign in to reply to this post

Eric Mittman

Renaming the configuration folder will force you to remove all of the installed extensions, there is no way around this when dealing with the configuration folder. This is not our workaround, it comes directly from Adobe. Here is a link to a page with more info on this and some of the other troubleshooting techniques when experiencing js errors with DW extensions:

tn_19105.html

Sign in to reply to this post

admin140217

Worked, then didn't

Eric,

I have done what you suggested and it worked at first and I was able to use the extention I wanted but then it went back to doing the same thing. Is it possible there is an issue with the extention or DWCS4?

Sign in to reply to this post

admin140217

Here's what I have discovered

Okay, since this happened again, I again renamed the configuration folder and removed every single extension I had installed. All extensions were installed through the extension manager from a fresh download of the product.

I opened DW to make sure all was okay and it was.

I started by installing site import 3.0.3 and opened DW, activated the extension and all is okay. I even imported a website to test it.

I installed many other non WebAssist extensions and after every extension I installed I opened DW and opened Site Import...no errors with it or other extensions.

I installed WebAssist Universal Email 4, I got no overwrite message in the extension manager, opened DW, activated it just to get it going and then closed it. When I tried to open SiteImport 3.0.3 again I got the same error message that started this. The error seems specific to Site Import, when I open UE4, there is no error.

In this experiment I can only conclude that there is some kind of error in the WA extension(s) that is not allowing it to work well with it's sister extensions. Am I wrong given the process I just followed?

What's my next step?

Please help, I can not keep going through this!

Thanks

Sign in to reply to this post

Eric Mittman

I have opened a ticket so that we can look into this issue further, to update the ticket login and visit your support history area:

supporthistory.php

Sign in to reply to this post

admin140217

updated ticket

Eric,

Thanks for opening the ticket, I did update the ticket information. long story short, I have nothing but WA extensions installed and although the Javascript error did not show right away as before, it did eventually.

Thanks

Sign in to reply to this post

Eric Mittman

It looks like there were a couple of issues going on. In the ticket you posted that you tried renaming the configuration folder and did not get the proper results after doing this. You then updated the ticket to say that after renaming the config folder you then had to delete the cache file to get things working without the js errors.

I noticed that there is no link to the steps for deleting the cache file so I'm adding the link here:

common_installation_issues.pdf

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...