close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Email not sending

Thread began 5/01/2010 7:09 pm by rick405729 | Last modified 5/07/2010 9:54 pm by Eric Mittman | 1706 views | 14 replies |

rick405729

Email not sending

I have created a default form with CSS Form Builder and used UE 4.0 to set it up to send to a single email address. Nothing seems to work . Everything seems to go fine, I get the confirmation page that I created but nothing comes to any email addresses that I put in. I have tried this with multiple email addresses and also with multiple websites with the same results.

I have exhausted all the things that I know to do and have spent way to many hours on this seemily simple project.

Please HELP....

Sign in to reply to this post

Eric Mittman

Please post back with the page that has the form on it as well as a copy of your webassist folder from the site. I will check on your page and test some things to see what might be going on.

Sign in to reply to this post

rick405729

Here is the website with the form.

contact.php

Sign in to reply to this post

Eric Mittman

Thanks for the link but I will need a copy of the php page and the webassist folder in a zip archive so that I can examine the php code and check on the various parts.

Sign in to reply to this post

rick405729

I have tried to upload the zipped folder but this forum only allows uploading of a file not a folder, unless I am doing something wrong.

Sign in to reply to this post

rick405729

How should I proceed

Sign in to reply to this post

rick405729

Here is the info that you requested.

Attached Files
contact.zip.zip
webassist.zip.zip
Sign in to reply to this post

Eric Mittman

What page are you getting to in the end? It does not look like you have any go to pages specified for the Universal Email sever behaviors that you have on the page. I'm not sure if the Universal Email server behaviors are being triggered properly.

To test out if the Universal Email server behaviors are being triggered add in this code to the following locations:

add a new line after line 50 and put this in the new line:

php:
die("got past the trigger for No Comments submit");



Then further down on the page just after line 138 add a new line and put this on it:

php:
die("got past the appointment submit");



When you save and upload the page test it out and you should be getting to one of the two messages. Post back and let us know the result that you get.

Sign in to reply to this post

rick405729

I added and uploaded the requested lines.
Here is the result:

got past the appointment submit

Sign in to reply to this post

Eric Mittman

That is a good start, at least the UE server behavior is being triggered. I have modified the webassist > email > mail_php.php to add in another debug line. Remove the lines that you just added on the contact page and use the updated version of this mail_php.php page. It should stop processing and print a message letting you know the mail call was successful, if the mail call was not successful you should get an error message about this as well. Post back and let us know the result that you get.

Attached Files
mail_php.zip
Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...