close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

cURL is not installed on localhost

Thread began 4/11/2010 11:27 am by anthony.tanner286315 | Last modified 5/28/2012 5:42 pm by Joia | 7450 views | 5 replies |

anthony.tanner286315

cURL is not installed on localhost

When I tried to install powerstore 3 on my local host I get this message "cURL is not installed. Contact your hosting provider to have cURL installed. "

Since this is my local host do you have any ideas of how I can overcome this problem.

I am using wampserver on vista home edition and I have successfully installed powergallery there so it seems wampserver is installed correctly

Regards Tony Tanner

Sign in to reply to this post

i.edwards384429

update

Hi

ok first create a blank php page and type in the following code

<?php
phpinfo();
?>

run the page ie previre in your local browser and you will see if Curl is installed and functional.

or

on your server icon in the bar at the bottom of your screen left click, select PHP select php extensions and check ifg Curl is ticked if not thats your problem.

One thing vista home edition does not have all the bells and whistles of the pro or ultimate so that may also be an issue.

I also suspect that gallery does not require Curl because as I understand it ( I'm not an expert) it's a library that allows connections to other servers such as Https so I suspect it's related to Paypal etc.

If this does not help post back with more details. I'm in the office tomorrow all day.

cheers

Ian

Sign in to reply to this post

i.edwards384429

more

Sorry senior moment, if Curlis not ticked in P|HP extensions. Double click on it and then use the option to stop services, then restart the services and Curl should now show as ticked and running.

cheers

Ian

Sign in to reply to this post

Joia

cURL is not installed. Contact your hosting provider to have cURL installed.

I am using Xampp and also had this problem.
I followed the instructions but was not successful.

How to enable this function on Xampp?

Sign in to reply to this post

gruant2000381341

you have to enable that in the php.ini file
in my version, it was in this location...yours may vary
c/xampp/php/php.ini

look for this line ( mine was around line 952)
;extension=php_curl.dll
remove the ; so it looks like this
extension=php_curl.dll
save it, and it should work for you
if you had xampp running...you will need to exit it and restart it for the changes to take effect

Sign in to reply to this post

Joia

resolved

It worked, thank you.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...