close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Code comments showing in mail preview

Thread began 4/07/2010 7:31 pm by bjgarner241692 | Last modified 4/08/2010 2:48 pm by Jason Byrnes | 1576 views | 11 replies |

bjgarner241692

Code comments showing in mail preview

Just setup my first UE4 form to email. I use Auto Preview in Outlook. When the email arrives I can see the first couple of lines of text to see if I want to read it or not. The message shows all of the code comments which really makes it look trashy.

I'm sure I can figure out how to delete it but it would be nice if the extension were fixed so that this extra step is not required.

Sign in to reply to this post

bjgarner241692

Excellent, after manually removing the offending code:

$MailBody = $MailBody . "<html><head><!-- In\"+\"stanceBegin template=\"/Templates/waue html body\" codeOutsideHTMLIsLocked=\"false\" --><!-- In\"+\"stanceBeginEditable name=\"emailhead\" --><!-- In\"+\"stanceBegin template=\"/Templates/waue html body\" codeOutsideHTMLIsLocked=\"false\" --><!-- In\"+\"stanceBeginEditable name=\"emailhead\" --><!-- In\"+\"stanceBegin template=\"/Templates/waue html body\" codeOutsideHTMLIsLocked=\"false\" --><!-- In\"+\"stanceBeginEditable name=\"emailhead\" --><!-- In\"+\"stanceEndEditable --><!-- In\"+\"stanceEndEditable --><!-- In\"+\"stanceEndEditable --></head><body><!-- In\"+\"stanceBeginEditable name=\"emailbody\" --><!-- In\"+\"stanceBeginEditable name=\"emailbody\" -->\r\n";
$MailBody = $MailBody . "<p>\r\n";
$MailBody = $MailBody . " <!-- In\"+\"stanceBeginEditable name=\"emailbody\" -->\r\n";


If you open the Behaviour again it comes back.

CSS menu writer has the exact same problem. When you manually fix things that should have worked in the first place if you have to go back into the tool it will overwrite all of your customizations.

Really, why is any of that code necessary?

Sign in to reply to this post

bjgarner241692

Just gets better.
File attachment has the same problem as pretty much every other dialog box in a WA extension. Pick or type what you want, then click somewhere else in the dialog box to set the field. Otherwise, your attachment will not be saved when you click OK.

Once you go back to do it AGAIN though you will find that your email will arrive with the attachment and nothing in the body except a 0.

Remove the attachment and the email will arrive with the proper body.

So glad I upgraded. 2.5 hrs invested now in sending 2 emails on submit.

Attached Files
waue_landing_3.txt
Sign in to reply to this post

neilo

Hi Bj,

I'm not sure how the actual text entered in to your form is getting written to the waue_landing_3-1.php file. This isn't usual behaviour (in my very limited) experience.

The waue_fileneme_1.php should look the same after sending the form as it does before, apart from the form bindings, (if you haven't used a template).

So if you are not using the 'create a file for your email:' but just using the 'edit' box (and adding the values dynamically from the form's fields in the bindings panel) the MailBody variables lines should look like something this (but reflecting the form fields)


$MailBody = $MailBody . "";
$MailBody = $MailBody . ((isset($_POST["message"]))?$_POST["message"]:"");
$MailBody = $MailBody . "\r\n";
$MailBody = $MailBody . ((isset($_POST["email"]))?$_POST["email"]:"");
$MailBody = $MailBody . "\r\n";
$MailBody = $MailBody . ((isset($_POST["name"]))?$_POST["name"]:"");
$MailBody = $MailBody . "";

and if you are usinng UE4 and have ticked the 'create a file for your email:' and chosen a template, the MailBody lines should still look like this:

$MailBody = $MailBody . "";
$MailBody = $MailBody . (GetFromPage("templates/Blank_1.php")); /* or what ever template you chose */
$MailBody = $MailBody . "";

I can't think of how the actual entered text from the form would show up in the waue_landing_3-1.php, unless you opened it and entered it there yourself.

Perhaps you could try a new test form using a different template, and do a test send without making any extra adjustment or formatting, to see what happens.

Sign in to reply to this post

bjgarner241692

Thanks for the attempt, but you are entirely incorrect. The contents of the email you want to send are written to this file by default.

This file has not been edited.

Sign in to reply to this post

neilo

Cheers bj,

I rarely manage to do anything in its entirety, so I am understandably pretty pleased with myself at the moment.

I do have a slight problem, though, and we may be talking at cross purposes. Are we both talking about the waue_sameasformfilename_1.php file that resides in the webassist/email/ folder? If so, I think mine must be faulty. Every time I use a form that has been sent using UE4 and therefore the waue_sameasformfilename_1.php that corresponds to it, the waue_sameasformfilename_1.php doesn't change in any way but retains the formats (as mentioned in my last post) for both the templated and un-templated versions; - I obviously presumed that this was so that when the next person who fills in and sends me an email from the same form page but with different information entered in to the form fields, I would receive that information, and not the same info that the last person sent or offending code and comments and stuff.

I also have a distinct disadvantage in that my emails are arriving perfectly formatted with the correct information and without any offending code and comments, which leaves me without anything to puzzle over.

If you could point out to me what I am doing entirely wrong, I would be most grateful.

Thanks.

Sign in to reply to this post

neilo

From the code that you posted, and that is being written to your page, it looks as though the server that your files are on may not be configured to render php pages, - it looks as though PHP code is being written to an html page.

Is the hosting server windows or Unix based, and do you have other php pages rendering correctly?

Sign in to reply to this post

bjgarner241692

My UA file in the webassist/email folder is named waue_landing_3.php because it is the third one created for the page.

The attachment was changed to a txt extension so that it could be uploaded.

Of course the user inputted content will not appear in this template file, but the body text that you add will. This is the only place it will appear.

Yes, my server displays .php just fine thank you.

Do you work with WebAssist, or are you just trying to be helpful?

Sign in to reply to this post

bjgarner241692

Uninstalled UE4, installed UE3, deleted .dat file to clear javascript errors.
set up forms to email again, works fine except that I can no longer browse to an attachment. The only selection is Dynamic.
Reinstalled DFP 2.0.3, still no file select.

WebAssist, if you have a solution which does not include deleting my Configuration File, please advise. If that is the next logical step I will replace all of the offending programs with DMX Zone products and I will be expecting refunds.

In the past week I have had failures with:
eCart
CSS Menu Writer
HTML Writer
Universal Email
Data Assist

All of which have required manually correcting code, deleting the config or removing and reinstalling the extension.

At a minimum, this has been 2 days of lost productivity.

I've uninstalled and reinstalled so many times that it is absolutely ridiculous. I have to logon to this site 6 to 8 times a day in order to look for solutions or retrieve serial numbers which simply adds to the immense frustration of owning several thousand dollars worth of extensions which DO NOT WORK AS THEY SHOULD!

Sign in to reply to this post

Jason ByrnesWebAssist

The problem with the template code being written to the mail body is an issue we discovered late lat week. It will only occur when using Dreamweaver CS3, and using the DW Edit icon to create the message body. We are working on fixing the problem, and have a fix available as soon as possible.

If you select the option to use one of the built in mail templates and save that as a file, the offending code will not added, after the universal email behavior has been applied to the page, the template file will open for you to edit.


  except that I can no longer browse to an attachment. The only selection is Dynamic.  



can you please clarify what you mean here so I can better understand the issue in order to offer a solution? perhaps if you could supply a screen shot, that will help me get a better idea of the issue.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...