close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

PS3 issues with advanced options and default values

Thread began 3/28/2010 9:49 am by email377288 | Last modified 12/01/2010 3:58 pm by Jason Byrnes | 2904 views | 15 replies |

email377288

PS3 issues with advanced options and default values

I am having the following issues with products setup using advanced options such as color and size:

Unless the product that uses the default values of the advanced options is made available online, no products in this group will show on the Products_Results page.

After discovering this I attempted to change the advanced options default values, to the values of a product that was available online, using the manage advanced options link. When I select new default values for an option I get a pop up box that reads "your default product has been changed" but then when I click close the default value returns to its old value and my new selection is not saved.

Any help would be greatly appreciated.

Cheers

Sign in to reply to this post

Eric Mittman

I have checked on this and regardless of weather my item's default options are set to be online or not I get the item to show up in the list.

There might be an issue with the options that you are using or the values for them. Please post back and include some example options for the product so that I can test with your specifics to see if I can get the same problem. This will help us to determine the nature of the issue and how to help you with it.

Sign in to reply to this post

email377288

The options I am using are the same for all products:

Color: White, Grey, Black

Size: l, ll, lll

On the Manage Inventory (options_Edit.php) page if you make the default product not available online a pop up box reads: "You have chosen to make the default value for this product unavailable. If it is unavailable this product and all associated options will no longer display in your product catalog. Are you sure you want to continue?"

While this is not ideal I accept it has been programmed this way.

My main issue is that when I try to select new default option values for a product I get the pop up box reading "your default product has been changed" but these changes do not save they simple revert back to there initial state.

Sign in to reply to this post

Eric Mittman

Thank you for the clarification. I have opened a ticket for you on this issue. To check the status or update the ticket please login and visit your support history.

supporthistory.php

Sign in to reply to this post

robert222776

Was there ever any resolution to this problem? I am having the same problem where advanced option (color) changes are non sticking after it has indicated that a change was successful.

Manage Advanced Options window, use drop down to change the color, message says the default option has been changed, click close and sometimes the default changes and sometimes it does not. Sometimes it appears to change, but changes back after a short delay.

A couple of times early on the change seemed to stick, but then when I clicked finish to close the MAO page, the option reverted to the original default.

Thanks,
Robert

Sign in to reply to this post

Eric Mittman

Here is the response from the ticket:

As a workaround currently, you will have to rename the current default option to the one you want the default option to be.

If the options don't change the price, you can set up simple options. It appears that the simple options will change the default option correctly.

Sign in to reply to this post

robert222776

Thanks Eric.

Since there are different inventory levels for each color, and since all colors have already been added, I think I need to make the change using the advanced option by re-naming the color....three colors actually....green to z-green, natural to green, and then z-green to natural to make "natural" the new default from the previous default green.

This is simple enough to do, but maybe not so easy to explain to a client (why there is a bug and why I am not fixing it). Is there a plan to fix this anytime soon in an upcoming revision?

Thanks,
Robert

Sign in to reply to this post

Eric Mittman

I have confirmed that this is logged as a bug but there is currently no ETA for a fix.

Sign in to reply to this post

kenstites342105

Originally Said By: Eric Mittman
  I have confirmed that this is logged as a bug but there is currently no ETA for a fix.  


Hi Eric,

I'm having this same problem. Has there been any progress in fixing this bug?

Doesn't the suggested fix of renaming the default option affect the product inventories? For example if renaming the default option from small to large, doesn't that make the products inventories for "large" change to the inventory counts that where associated with the small option?

As anyone tested to see if this bug is fixed in PS4?

Thanks,
Ken

Sign in to reply to this post

Jason ByrnesWebAssist

This bug is fixed in both PowerStore 3.01 and PowerStore 4.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...