close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Line item 1 is invalid(Cant find solution in forums)

Thread began 3/11/2010 3:56 pm by Nenad | Last modified 3/12/2010 8:08 pm by Jimmy Wu | 725 views | 4 replies |

Nenad

Line item 1 is invalid(Cant find solution in forums)

Hello,
I am receiving the error "Line item 1 is invalid." I have looked at all relevant posts on the subject and tried all solution currently available in this forum with no avail.

When we look at the full request below there doesn't seem to be 'line_item=1'. There is a 'line_item=2', but no 'line_item=1'

The Name does not have any HTML characters in it. The description field is empty. I also tried putting a value in this field but still doesnt work. I created a new unique column in ecart called "Package" that also does not contain any HTML characters. This column is supposed to pass through, hopefully I did this correctly. In the database the ProductName is varchar(100) and Package is varchar(50).

Im not sure what to try any more. Please help! The responses are below, I replaced all of my personal information with *. I also attached the confirm.php.

Thank you in advance for you help. And please, I need a solution ASAP, this is very important. THANK YOU SO MUCH!

****ERROR****
3

1

270

Line item 1 is invalid.

****FULL RESPONSE****
3::1::270::Line item 1 is invalid.::::P::0::4j29sceaeq640hl77vpa::1 Playboy Golf (2)::1.00::CC::auth_capture::::*******************::::**************::Elmhurst::IL::*****::US::*******************::::*********************::*****::*******vsic::::*****************::*************::**::*****::US::::::::FALSE::::7DC89A59B81120B256371D7F5AC60639::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::*************::

****FULL REQUEST****
x_login=*******************x_tran_key=****************&x_version=3.1&x_invoice_num=4j29sceaeq640hl77vpaaqugf2&x_test_request=FALSE&x_method=CC&x_type=AUTH_CAPTURE&x_relay_response=FALSE&x_delim_data=TRUE&x_delim_char=::&x_customer_ip=*****************&x_amount=1.00&x_description=1 Playboy Golf (2)&x_line_item=2<|>Playboy Golf<|>TEST PRODUCT<|><|>1<|>1<|>YES&x_card_num=*******************&x_exp_date=****&x_card_code=***&x_email_customer=TRUE&x_tax_exempt=FALSE&x_first_name=*********&x_last_name=*************&x_address=******************&x_city=Elmhurst&x_state=**&x_zip=**************&x_phone=**************&x_fax=&x_email=****************&x_country=US&x_ship_to_first_name=************&x_ship_to_last_name=*************&x_ship_to_address=*****************&x_ship_to_city=*****************&x_ship_to_state=**&x_ship_to_zip=*****&x_ship_to_country=US&x_ship_to_phone=*************&x_ship_to_fax=&x_currency_code=USD&x_recurring_billing=NO

Attached Files
confirm.php.zip
Sign in to reply to this post

Nenad

Nevermind.....solved

Nevermind my thread, it is solved now.

Thanks!

Sign in to reply to this post

Jimmy Wu

It would be very much appreciated if you could post up your resolution to the issue in case any other users run into the same issue. Thanks, and I'm glad you were able to get your issue resolved. If you run into any additional issues, feel free to open a new thread.

Sign in to reply to this post

Nenad

Hey Jimmy,

I just had some junk code that was throwing it off. Unfortunately it is nothing that can help anyone here. It was just some code that I tried adding for another feature, once I removed it it worked.

Nick

Sign in to reply to this post

Jimmy Wu

Ah, well, glad you got it resolved.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...