close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Character Sets and Collations

Thread began 3/11/2010 7:15 am by anlanza297228 | Last modified 3/17/2010 6:22 am by Rune Brynestad | 878 views | 7 replies |

anlanza297228

Character Sets and Collations

Hello,

There are data in the results shown in symbols.

And when I insert a new record with ñ, á, é, I see bad data in the table in MySQL.

I realize that is a problem of Character Sets and Collations, but do not see how to fix it.

Attached two pictures.

Thanks for your assistance.

Sign in to reply to this post

Jason ByrnesWebAssist

You need to change the character set on the table.

To do this, you will need to use a GUI tool for managing your MySQL database. It can be done using myPHPAdmin, or a tool like SequalPro. I am including a screen shot showing how to modify the encoding in SequalPro.

Sign in to reply to this post

anlanza297228

I use phpMyAdmin.
I have configured for the database and table utf8_general_ci
I tried other character Sets, and still have the same problem.
What character Sets should I use?

Sign in to reply to this post

Jason ByrnesWebAssist

I usually use the default latin1_swedish_ci character set and do not have a problem.

Sign in to reply to this post

Miguel

check your pages that each contain for utf-8 the correct charset


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />




charset=UTF-8

Sign in to reply to this post

anlanza297228

If you found that PHP documents are generated DataAssist charset=utf-8.
And my database and table are in utf8_general_ci.
What was left was the default when you install version 3.2.0.1 of phpMyAdmin.

Sign in to reply to this post

Jason ByrnesWebAssist

I have not run into a problem using UTF-8 php pages and the latin1_swedish_ci character set in MySQL

Sign in to reply to this post

Rune Brynestad

If you have special characters in your language like ñ, á, é or æ, ø, å it's safest to use utf-8 all over.
Here's a setup that works for me:

In your PHP page, use utf-8 as your charset like this:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

In your MySQL database:
Use utf8 -- UTF-8 Unicode as your Character set and utf8_yourlanguage here_ci as your Collation

In your connection string:
Add this line at the end of your connection string: mysql_query ('SET NAMES `utf8`');

Hope that helps.

Regards
Rune

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...