close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

PS3 + insert / add a new page

Thread began 3/05/2010 9:26 am by gw311682 | Last modified 3/12/2010 6:20 pm by Jimmy Wu | 1359 views | 11 replies |

gw311682

PS3 + insert / add a new page

Hello,

I want to add a page called ‘news’ to my site. This needs its own entry on the navigation bar, just like ‘Support’, etc.

So far, I’ve created a new page from the main template (using DW CS3) and named it news.php. The only problem is that once I put anything in the editable content, it expands to take up the whole width of the page. It would appear that the categories (div?) are not moving left and the editable content is floating over them.

Any ideas appreciated.

Sign in to reply to this post

Jimmy Wu

I'm not able to reproduce the error. What I did was create a new page, applied the template and then added something to the MainContent editable region.

Can you send me a link to the page that is having an issue?

Sign in to reply to this post

gw311682

Hello Jimmy and thanks for getting back to me.

When I first created the page, I created it by going to File > New > Page from Template > msebooks (site) > main (template).

I then tried your method: File > New > Blank Page. Once the page was created I saved it as a php type file called news.php. I then went to Modify > Templates > Apply Template to Page and attached the main template.

No luck though, I still get the same problem. Unfortunately, I can't send you a link as the site / file is on my testing server, which is a XAMPP installation on my PC. However I have attached a copy of the file which I've just created using your method. Maybe this will be of help?

Looking forward to your reply and thanks for your help.

Attached Files
news.zip
Sign in to reply to this post

gw311682

Hello Jimmy,

I've wrestled with this problem all over the weekend and throughout today with no luck. My only conclusion being that for some reason when the main template is attached to the new page, it’s not referencing one or more of the style sheets it needs to display correctly.

(If memory serves, there seems to be a difference in the way the codes treated on the page I’ve sent you at around line 189 in comparison, say, to the code on the page Ordering.php. But this could just be me clutching at straws.)

In light of my failure to get any further, and without wishing to seem like I'm whinging, I need some help with this sooner rather than later. It’s been 5 days since I posted this problem and it’s now beginning to cause a real site development bottleneck. So, Jimmy, a response would really be appreciated.

Thanks and kindest regards.

Sign in to reply to this post

Jimmy Wu

When I put your page into my local PowerStore setup, I didn't see the error you are referring to. When I preview the page in the browser, I get the categories accordion and the content. Can you take a screen shot of what is happening on your end? What browser are you using to view this?

Sign in to reply to this post

gw311682

Hello Jimmy and thanks for getting back to me.

I’ve put together the screenshots you’ve asked for in a number of different combinations. For example, in different browsers and in DW’s code / design view.

I’ve also included screenshots of the Ordering.php file as a check file - as you’ll see there are no problems with the way this page displays.

Having looked at it again, my thought (without stating the blindingly obvious) is that it seems to be a float / wrap / display problem. But I can’t figure out why for the life of me.

Interestingly enough, if I make a copy of Ordering.php and rename it, the renamed page displays OK.

The only other thing I can think of that may affect it for some reason is that I’ve used the workaround you gave in post show...2499#post42499 to start altering the site’s main navigation. (This is one of the reasons for the news page - so I can make all navigations changes in one go.) However, while I’m using the new, downloaded treexml file, at this stage I haven’t altered lines 2 & 3 as mentioned in your post for two reasons.

One, I haven’t finished altering the navigation yet but two, which lines 2 & 3? I can’t find anything remotely like the example you give in my treexml.xml. And I’ve compared the old file with the new file to try and spot the lines of code you mean. So, to be more safe than sorry, I’ve also sent you this file to have a look at just in case it’s the problem.

I hope I’ve covered everything now, Jimmy, and given you enough info to work on. Looking forward to your reply, best wishes.

Attached Files
news page screenshots1.zip
news page screenshots2.zip
news page screenshots3.zip
Sign in to reply to this post

gw311682

Since my last post, I've downloaded PS3 again to make sure I have a fresh copy of the main template. When I look at this in DW or a browser, the problem that I'm experiencing is clearly shown to be in the template. Don't know if this helps or not.

I hope that by now, Jimmy, you've had time to look at the screenshots I sent in yesterday's post. Would really appreciate a reply ASAP as it's now seven days since I started this thread. Looking forward to hearing from you soon.

Sign in to reply to this post

Jimmy Wu

I'm not sure which workaround you're referring to, since the link you posted is broken. If you think it may be an issue however, you should revert the changes and go back to the original and try it again.

As for making a copy of the Ordering page and having it work. Would it work for you to make a copy of the Ordering page and modifying it to be what you want for the news page?

I can see that there is a problem occurring when you apply the template and add content, but I haven't been able to reproduce the same issue. Does this happen with the default template that is provided in the PowerStore as well or is it only after changes were made to the template?

Sign in to reply to this post

gw311682

Hello Jimmy and thanks for getting back to me.

The workaround I mentioned is the one relating to being unable to alter the site’s navigation using CSSMW. When you try to alter the navigation using CSSMW the error message, “The database connection for this content preset does not exist..." appears. This problem seems well documented in the forum.

As I mentioned in yesterday’s post, I have downloaded a fresh copy of PS3. I opened the main.dwt (read only mode) in Dreamweaver CS3 without altering it. No luck, exactly the same problem in DW design view and all of the four test browsers I use.

Clearly, I could just make a copy of an existing page but I really think this would be a cop out. I would like the programme to work, as it should, by being able to create a page from the template or attach the template to a new page. So, if you can persevere with this problem for a little while longer, I’ll really appreciate it.

Once again, Jimmy, thanks for your help and patience.

Sign in to reply to this post

gw311682

Just a quick update, Jimmy.

As a double check to my posting earlier today, I set up a completely new site (checksite) on my testing server (XAMPP) using a new PS3 download. This site is on an ‘as is’ basis, i.e. the files are exactly as downloaded from WebAssist and they haven’t been modified in any way at all.

As you can see from the attached screenshots, the main.dwt.php template still has a problem with the text shifting to the left and covering the area where the categories accordion should be. However, as you’ll see from the Ordering.php screenshot, from the same site, this page is OK and everything lines up, as it should.

If you can’t recreate this problem, maybe you have a different main.dwt.php file than the one included in the PS3 zip download? Only a thought but maybe it’s worth a look at.

Looking forward to hearing from you with your thoughts based on my further research into this problem.

Attached Files
PS3 screen shots1.zip
PS3 screen shots2.zip
Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...