close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

installed - logged in, but index.php is blank...

Thread began 3/02/2010 4:25 pm by jeffmg279672 | Last modified 3/06/2010 6:04 pm by jeffmg279672 | 3351 views | 9 replies |

jeffmg279672

installed - logged in, but index.php is blank...

Hi. I thought from reading through the spec that PowerCMS would be the solution I was looking for, but I've hit a problem which I can't seem to unpick.

I've done everything that is set out in the PDFs in terms of installing/uploading, db connection script, setting WA_Globals.php etc, but although I get the splash screen with the login box, after I've logged in, I get a blank page where admin/index.php should be.

I should point out that I've installed this on my testing server (MAMP) as I want to run it first and ensure that I can do what I want with the content of an existing site which I need to convert to CMS for a client, so I've got everything set up in a local folder as normal, with the testing server as localhost:8888/mydomain/CMS/admin/

that's where it's all come to a halt - blank index page so although I'm logged in, I can't do anything and I have no idea where to go from here...

Sign in to reply to this post

Eric Mittman

You should enable error reporting by putting in this php code at the top of your page:

php:
<?php 

error_reporting
(E_ALL); 
ini_set('display_errors','on'); 
?>



This should let you know what the problem is, if you have any trouble getting past the error let us know what it says.

Sign in to reply to this post

jeffmg279672

Hi Eric - Jason Byrnes suggested this with a problem I was having with a project that involved DataAssist recently - problem is that MAMP seems to have reporting turned off and I can't see how it can be switched on, so when I tried this I got a blank page. I'll try checking the MAMP support forum and see what they can suggest.

Sign in to reply to this post

Eric Mittman

I'm not too familiar with the MAMP setup for php but these settings should be defined and set in your php.ini file. If you create a php info page you should be able to find the loaded ini file and adjust it there.

To make a phpinfo page add this line of code to a new php page or an existing one:

php:
<?php phpinfo(); ?>



In here look for the loaded configuration file setting at the top of the listing. This is where your ini file should be, if you can adjust this file you should be able to turn the display errors setting to on, and set the error reporting to E_ALL.

Sign in to reply to this post

jeffmg279672

Hi Eric

I've changed the settings on MAMP so that I'm now getting error messages, and the result is the following:

Notice: Undefined variable: database_localhost in /Applications/MAMP/htdocs/pillarpoint/CMS/admin/index.php on line 46

Notice: Undefined variable: localhost in /Applications/MAMP/htdocs/pillarpoint/CMS/admin/index.php on line 46

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /Applications/MAMP/htdocs/pillarpoint/CMS/admin/index.php on line 46

Notice: Undefined variable: localhost in /Applications/MAMP/htdocs/pillarpoint/CMS/admin/index.php on line 48

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /Applications/MAMP/htdocs/pillarpoint/CMS/admin/index.php on line 48

Hope this helps...
Jeff

Sign in to reply to this post

Eric Mittman

That helps a lot. The errors you are seeing are letting you know that the db variables on the page do not have the proper values. These variables are defined and set in the connections file. If this connections file is not included before the variables are referenced then you will get these errors. You need to ensure that you have the include for the connection file at the top of the page and that the connection file is properly crafted.

The connection file include line should be at the top and it looks like this by default:
<?php require_once('../Connections/localhost.php'); ?>

It is looking in the parent directory for the Connections folder and the file inside of it. Also, you must ensure that you have the proper values in this file.

Sign in to reply to this post

jeffmg279672

Thanks Eric - I've not changed anything in the code for admin/index.php so not sure why it was throwing this error. On the basis of what you said though, I've moved the Connections/localhost.php up to the top of the includes list on this page, but I still get an error.

I've zipped the connections/localhost.php page and the globals page together with the admin index.php page in the hope that it might be something basic and stupid that I've done here.

Attached Files
Archive.zip
Sign in to reply to this post

jeffmg279672

Since sending the previous post I've ditched the original install of PowerCMS and started over. I then changed the admin/index.php page so that instead of saying:
mysql_select_db($database_localhost, $localhost); at line 42
it now reads:
mysql_select_db($database_cms, $cms);

I then tried opening admin/index.php in the browser from inside MAMP and it took me to the right page (although worryingly without having to log in) and the next problem is that when I click on either of the View/Edit Content or Insert New Content tabs, I get a 404 with this URL coming up in the browser, which suggests that the /CMS/ setting for both local and remote is wrong:

contents_insert.php

it should be: contents_insert.php

and if I add the missing word into the nav bar, it brings up the correct page. So... I assume that this is a case of something adrift in the WA_Globals.php page settings - am I right, and if so, what should I have in there to put it right?

Attached Files
powerCMS_screenshot.zip
Sign in to reply to this post

Eric Mittman

I have opened a ticket for you on this connections issue so that we can look into it further. The default PowerCMS files should reference $localhost for the connection information. The connection file included with PowerCMS should be called localhost and contain the defined localhost variables.

To update your ticket login and visit your support history, here is a link:

supporthistory.php

When it comes to the URL what you do have specified in your globals file for the local and remote URL values? Based on the results you posted you should have the local root URL set like this:

/pillarpoint/CMS/

Sign in to reply to this post

jeffmg279672

I think I've fixed it...

I've changed the local & root settings as suggested, but I was still getting the same sort of error messages on-screen when trying to navigate from admin/index.php using the nav tabs at the top of the screen.
So... I've been through content_insert.php, content_results.php, content_detail.php and in code view have changed all instances of "localhost" to "cms" and that seems to have sorted it - at least, the pages are displaying properly on-screen and I've added some test content and can view it, so my plan is to go through the other admin folder pages and make this a global change.

One thing I would like to clarify though, is this. I have a smallish (12 pages of static HTML) site which I need to convert so the client can update the content themselves (which is why I went for PowerCMS in the first place). I want to use the existing site content exactly as is, and want to use the existing CSS for the site rather than whatever comes bundled with PowerCMS. How exactly do I do that?

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...