close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Javascript error at ThemeIt launch

Thread began 2/22/2010 9:48 pm by swrmick260574 | Last modified 3/09/2010 11:04 pm by iggymak198560 | 3278 views | 25 replies |

swrmick260574

Javascript error at ThemeIt launch

Hello,
I am having problems getting ThemeIt to run.
I have installed and activated it.
With a new html page consisting of one coloured word and cursor focus within the page design view, I use the main menu to open ThemeIt. (Insert => Webassist => ThemeIt)
The themeIt interface opens, but with nothing in the left panel.
At this moment a javascript alert appears with the text;
"While executing onLoad in wa_managetheme.htm a JavaScript error occurred." (see attachment 1.jpg)
When the "OK" button is clicked, an identical JavaScript alert appears.
When "OK" is clicked the second alert disappears and the themeIt interface remains, but with nothing in the left panel.
If either left panel tab ("Manage Colors", "Manage Images"), or the "Preview" tab in the right panel is clicked a new JavaScript alert appears, with the text;
"While executing onMouseUp in wa_managetheme.htm a JavaScript error occurred."
When the "OK" button is clicked, an identical JavaScript alert appears.
When "OK" is clicked the second alert disappears and the themeIt interface remains, but with nothing in the left panel.
The Color Importer appears to be working correctly. It will display either a local html page or the webassist.com homepage.
When the ThemeIt window is closed, a JavaScript alert appears with the text;
"While executing timer in wa_themeit.htm the following error(s) occurred.
at line 127 of the file C:\Program Files (x86)\Adobe\Adobe Dreamweaver CS3\configuration\Floaters\wa_themeit.js: TypeError: MM.updatedImages[image].imageProps has no properties." (see attachment 2.jpg)
On inspection the file wa_themeit.js does not exist in that location. (see attachment 3.jpg)
System:
Vista 64 bit
Dreamweaver CS3
Most webassist extensions installed, plus 4 or 5 non webassist extensions.

Sign in to reply to this post

swrmick260574

Additional Information

To troubleshoot the problems I have;
Re-downloaded the extension. the file sizes were identical. (5.15 MB (5,407,530 bytes))
Disabled/Re-enabled the extension numerous times.
Uninstalled/Reinstalled the extension numerous times.
Deleted winFileCache.dat numerous times and allowed dreamweaver to recreate it by Starting then Closing Dreamweaver.
Restarted the PC numerous times during troubleshooting process.

Sign in to reply to this post

82rocktoy128440

same problem

I am having the same problem!

Sign in to reply to this post

p.woodall208922

Totally predicable error prone launch of new product

Me to!

Another example of WebAssist producing a defective product.

Web Assist have you not heard about PRODUCT TESTING BEFORE you take our money.

Sign in to reply to this post

Doris371530

Problem

I have one error coming up, which stops the programm. Spend all morning with it. Does not work!

Sign in to reply to this post

Ray BorduinWebAssist

We have been working with users through our support incident system and have identified and fixed several bugs causing issues.

We do product testing and even have a small beta group that helps, but everyone's site, page, css, and system is unique, so unfortunately the day after a large release when it gets into hundreds of people's hands we sometimes run into errors.

We are working hard to address those errors now and will be creating a dot release in the next couple of days to address any issues we find.

If anyone would like immediate assistance, email me at ray@webassist.com and include your phone number and I will personally call and debug the issue with you until it is resolved.

Sign in to reply to this post

swrmick260574

Not solved yet.

Installing Theme-It 1.0.1 Build 019 (Beta) does not change any of the symptoms I described here in my system.

Sign in to reply to this post

Ray BorduinWebAssist

I have opened a support incident so that we can work with you directly to get this issue resolved.

Please update your support incident with a phone number where we can contact you and we will get in touch with you as soon as possible to debug this issue.

Thank you for your patience.

Sign in to reply to this post

ernietamminga142573

Theme-It just installed; doesn't work

I too am getting the JavaScript error when trying to use Theme-It.
I already tried the usual route of deleting the Win Cache file. Doesn't change anything.

"At line 411... wa_themeit.js;dims has no properties.

I'm using Dreamweaver CS4.

VERY frustrating.

Sign in to reply to this post

82rocktoy128440

broken

I too Installed Theme-It 1.0.1 Build 019 (Beta) and when I start DW I get an error message and when I try to run Theme It nothing happens, don't open!

"unable to find file wa_themeit.html in the configuration/floaters directory"

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...