close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Verify Email Confirmation not working

Thread began 2/19/2010 7:09 pm by dcb286193 | Last modified 3/01/2010 5:56 pm by Eric Mittman | 2392 views | 11 replies |

dcb286193

Verify Email Confirmation not working

I am testing PowerStore 3 and have placed an order. Everything confirms and emails are sent. When I go to finalize my Email Verification it says it confirms the email but does not set confirmation. It stays on "Email Confirmed: NO".

I have confirmed the email several times with each time it not confirming. Any suggestions?

Sign in to reply to this post

Eric Mittman

Login to your db and check the ps3_users table. Look at the user you have verified the email address with and look at the UserEmailVerified column. It should be set to 1 for users that have been verified and 0 for the ones that have not.

Let us know what you discover, if it is one for your user then it is the error message that is incorrect, if the value is 0 then it is the confirming of the email that is the problem.

Sign in to reply to this post

dcb286193

Eric,

It is set to Zero. Below is the link to verify the email incase this helps.

Please follow the link below in order to verify this email address:

users_Confirm.php?ID=1=LrgohPVc5Z0P7gPCL36z

Like I said when I click on the link to goes to the verification page and says:

Thank you for verifying your email address.

Please login in order to access your order history.

Then when I go to try and login it says:

Your email address has not been verified.
You will need to verify your email address before gaining access to your order history.

So for some reason it it not changing the 0 to a 1 on the confirm page.

Sign in to reply to this post

Eric Mittman

It seems like you may not be triggering the update on the user confirm page to make the userEmailVerified a 1.

When I look at the link closely I can see that you are missing a parameter, the link is:

http://www.togdcc.com/users_Confirm.php?ID=1=LrgohPVc5Z0P7gPCL36z



After the ID=1 there should be a &code that is missing. The formatting that makes this is held in the Universal_Email > Templates > registration.php and verification.php. Have you made any edits to these pages? If so you should get them back to their original state to have them work. If you have not made any edits to these pages please post back with both of them attached to your reply in a zip archive so that I can take a look at them.

I will let you know what I discover. If I can't resolve it quickly for you I will open a ticket.

Sign in to reply to this post

dcb286193

Verify Email Confirmation not working

I have made no modification to these pages, I have attached them. When I look at the files the &code is there, so I have no idea why it is not working correctly. I tried to verify the registration once again and received the same link message back.

Let me know what you find out.

Thanks.

Attached Files
Archive.zip
Sign in to reply to this post

Eric Mittman

The code is definitely there in the template pages. I did a test on your site and registered a new user, first name WA last name Test. I got the verification link in the email and can see that the code parameter is there like it should be.

When I clicked on this link it took me to your confirmation page and it told me my email had been verified.

Take a look at this user's record in your db and check the UserEmailVerified column. If it is not set to 1 please post back with a copy of your users_Confirm.php page. I will do a quick check to see if I can spot a problem and if not a ticket will be opened.

Sign in to reply to this post

dcb286193

I checked and everything is correct. I would like to know why it is not working for me. I will try again and log in using a different name to see if I can issolate what is going on from my end. I will let you know if I have further issues.

Sign in to reply to this post

Eric Mittman

Let us know what you discover, so long as the link has the code and id parameters and they match for the user in the db it should update the record and set the UserEmailVerified column to 1.

Sign in to reply to this post

dcb286193

For some reason the email sent is correct at the server but when Entourage gets it the &code is being deleted. I set up my email account using the mail program that comes with the mac and that does not strip out the &code. Very strange.

This brings me to another issue. When you registered I am to get an email stating their was a new registration. And, when you verify I should be getting another. Neither of these came. I did receive them when I registered not when you registered. I check the email server and they did not show up there either. Any suggestions.

Sign in to reply to this post

Eric Mittman

By default the only one that gets these emails is the user registering. If you would like to get a copy sent to your email you can add it to the BCC in the WA_UniversalEmail > WAUE_users_Profile_1.php and WAUE_users_Registration_1.php. In these files at the top you can enter your email address for the bcc like this:

php:
$MailBCC = "youremail@yourdomain.com";
Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...