close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

problems with WA_Globals.php

Thread began 3/29/2010 8:36 am by caryn191788 | Last modified 3/30/2010 8:43 pm by caryn191788 | 1430 views | 6 replies

neilo

The WA_Globals.php file for the PowerCMS version 102 is this (as it comes in a fresh download):

<?php
$WAGLOBAL_Site_Name = "Admin Site Title" ;

$WAGLOBAL_localRoot = "/PowerCMS folder/"; //relative path to your PowerCMS files on your local testing server.
$WAGLOBAL_remoteRoot = "/PowerCMS folder/"; //relative path to your PowerCMS files on your remote server.

// Admin Settings
$WAGLOBAL_Admin_UserName = "Please enter your admin username" ;
$WAGLOBAL_Admin_Password = "Please enter your admin password" ;
?>



So as your CMS files and folders have been put in a folder on your remote server called 'CMS', the WA_Globals.php file you will upload to your remote site will be:

<?php
$WAGLOBAL_Site_Name = "Admin Site Title" ;

$WAGLOBAL_localRoot = "/CMS/"; //relative path to your PowerCMS files on your local testing server.
$WAGLOBAL_remoteRoot = "/CMS/"; //relative path to your PowerCMS files on your remote server.

// Admin Settings
$WAGLOBAL_Admin_UserName = "youradminusername" ;
$WAGLOBAL_Admin_Password = "youradminpassword" ;
?>



Don't forget to enter your own Admin username and Password.

Your CMS folder is correct, because if you go to your admin help page, you can see the correct path in the browser address bar.

If you replace 'help.php' with 'index.php' I see a blank page which indicates that there is a problem with that page. I should see a login page.

If I go directly to: users_login.php , then I see the login page.

First thing I would try would be to add error reporting code:

<?php
error_reporting(E_ALL);
ini_set('display_errors','on');
?>


to the very beginning of your CMS/admin/index.php page and re-upload it, and hopefully this should print out to the page what error is preventing the page from loading. This may help us to diagnose your problem.

My second suggestion would be to just re-upload afresh PowerCMS files and folders to the CMS directory on your remote site, having altered the WA_Globals php file as above.

The pdf you refer to is outdated and should have been replaced, and yes - that does add to the confusion.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...