close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

Manage Relational Tables not working

Thread began 2/17/2010 10:37 pm by tim383164 | Last modified 2/23/2010 5:53 pm by tim383164 | 976 views | 6 replies

tim383164

Jason

I did what you suggested and added that additional line of code into both the Insert and Update Page, and guess what it worked.

While I have been waiting for this response, I did another test of this where I added an additional field into the link table called 'ShirtNo'

What I eventually want to do is when a Player registers and selects the teams that they will be playing in, they will enter what their shirt number is for that team.

E.g. Bob in Team A will have Shirt No 33 and in Team B will have Shirt No 27

So My link table should show something like

pkRepPlayerID - fkPlayerID - fkTeamID - ShirtNo
1 - 1 - 15 - 33
2 - 1 - 16 - 27

When I went through the steps I added a text box for ShirtNo into the RepeatRegion table and when I went through the MRT wizzard, in the last step I allocated the value of the text box into the ShirtNo table field.

When I tested this (which was prior to your response) I would get the entry into the link table for the last team id ok but I would get a null value for the ShirtNo field.

I then reran the MRT wizzard, but noticed that after the MRT has been applied I noticed that the binding for the ShirtNo field was now blank and I could not seem to find a value from the Lightning bolt to bind to it.

If from your last posting telling me to add a extra line of code into the Insert / Update Page (which has fixed the issue of selecting multiple items for Insert & Update) it seems to me that there seems to be some issues with the way the MRT process writes it's code. Coupled with the fact that I cant seem to be able to also add additional data into the linked table (which from reading previous posts in this forum) you should be able to do so.

I am running the latest version of DataAssist (2.0.6) which was installed into Dreamweaver CS4 on a clean build on WIndows 7 (ie no previous version was installed prior) so that rules out any extension upgrade hangovers

So is this a bug. Will it be fixed in later dot releases of DA?

When you have spent a lot of money (I purchased the SuperSuite) and find that in order to run a standard extension which doesnt seem to work properly (ie not inserting code) that it should, and you have to get lines of code from your company (which I do appreciate the support process) to make these things do what they should. Means that to use a set of tools that should make the development cycle reasonable quick especially for people just starting in this game and then we have to remember to add a line of code that doesnt get inserted into future implementations, seems to defeat the purpose of using these tools in the first place.

To be fair, I have not tried to this run this MRT before so I cannot say for certan if this incident is because this line of code isnt part of the wizzard creation process or wether it is a weird Dreamweaver having glyches running extensions thing. (ie On my previous platform, that was 32bit Vista 4 GB Ram I had a huge number of failings trying to run through the Site Assist Pro wizzard for example, where screens would lock up all the time, now that I am on this new platform with 8 GB ram 64bit I seemed to now have less of these issues, although not fully tested running Site Assist yet.)

But now that I have got the insert / update part working, I will now recompile a fresh page and start this MRT process again, this time trying to get the additional fields (shirtNo) to add. If I am unable to do so Ill attach the new .php pages for you to look at.

Regards

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...