close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

HTML Editor Styles Not Diplaying

Thread began 2/15/2010 10:46 am by fire MUNKY (Roy) | Last modified 2/15/2010 2:40 pm by fire MUNKY (Roy) | 922 views | 2 replies

fire MUNKY (Roy)

HTML Editor Styles Not Diplaying

I am having an issue with Styles in the HTML Editor.
I have read all the comments on the Forum here and still no joy.

Commented out the RED default Style.

Use the Wizard to set up a Custom Editor in the Styles Tab at the end I browse to the .css file and it finds it fine. All the Styles appear in the Editor Box. I choose the Body Style for the Body Selection and I CTRL select all the other styles to supposedly add them to my Drop Down List of available styles in the Editor on the Server.

Having checked the .js files the XML is produced although it is always produced unformated, and I have to correct the layout, structure. Still the right file is produced. I upload the relevant files.

Then when it comes to the on the SERVER there are no Styles in the Style Drop down at all. What looks like a black line appears as if there is something behind but it is not.

Any advice?

The .js for the Editor is below and below that is the .xml

Admin_Contact_update_GuitaristContactCopy1.js

// Custom configuration for iRite
FCKConfig.XMLFullName = 'Guitarist_Contact_Editor';
FCKConfig.XMLFileName = 'GuitaristContactEditor.xml';
FCKConfig.SkinPath = FCKConfig.BasePath + 'skins/silver/'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.DocType = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">';

FCKConfig.AutoDetectLanguage = true;
FCKConfig.DefaultLanguage = 'default';

FCKConfig.StartupFocus = false;
FCKConfig.FullPage = false;

FCKConfig.BaseHref = '';
FCKConfig.DefaultLinkTarget = '_blank';

FCKConfig.ToolbarSets["Custom"] = [ ['Source'], ['Image','Table','Rule','SpecialChar','PageBreak'], ['Link','Unlink'], ['Cut','Copy','Paste','SpellCheck'], ['Undo','Redo','-','RemoveFormat'], '/', ['Style','FontFormat','FontName','FontSize'], '/', ['Bold','Italic','Underline','StrikeThrough'], ['TextColor','BGColor'], ['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull'], ['OrderedList','UnorderedList','-','Outdent','Indent']]; /* Toolbar end */

FCKConfig.ForceStrongEm = false;
FCKConfig.FormatIndentator = ' ';
FCKConfig.EnterMode = 'br';
FCKConfig.FillEmptyBlocks = false;
FCKConfig.FormatOutput = false;
FCKConfig.FormatSource = false;
FCKConfig.IncludeGreekEntities = false;
FCKConfig.IncludeLatinEntities = false;
FCKConfig.ProcessHTMLEntities = false;
FCKConfig.ProcessNumericEntities = false;
FCKConfig.AdditionalNumericEntities = '';
FCKConfig.ForcePasteAsPlainText = false;
FCKConfig.CleanWordKeepsStructure = false;


FCKConfig.EditorAreaCSS = 'css/EditorHTML.css'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.BodyClass = 'body';
FCKConfig.StylesXmlPath = '../custom/Admin_Contact_Update_undefinedStyles1.xml'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.ManagerEnabled = true;
if (true) {FCKConfig.Plugins.Add('kfm');}

The Admin_Contact_Update_undefinedStyles1.xml is

<?xml version="1.0" encoding="utf-8" ?>
<Styles>
<style name="a" element="span" >
<Attribute name="class" value="a" />
</style>
<style name="backToTop" element="span" >
<Attribute name="class" value="backToTop" />
</style>
<style name="body" element="span" >
<Attribute name="class" value="body" />
</style>
<style name="first" element="span" >
<Attribute name="class" value="first" />
</style>
<style name="hr" element="span" >
<Attribute name="class" value="hr" />
</style>
<style name="imgBox" element="span" >
<Attribute name="class" value="imgBox" />
</style>
<style name="imgBoxColumn" element="span" >
<Attribute name="class" value="imgBoxColumn" />
</style>
<style name="imgBoxLeft" element="span" >
<Attribute name="class" value="imgBoxLeft" />
</style>
<style name="imgBoxTwoColumn" element="span" >
<Attribute name="class" value="imgBoxTwoColumn" />
</style>
</Styles>

All files are uploaded. I have even deleted everything on the Server and reuploaded new.
Still no joy.

Thanks

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...