View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

insert or update on login

Thread began 10/14/2009 1:38 pm by Daryl | Last modified 6/21/2010 2:55 pm by Daryl | 1510 views | 11 replies

DarylBeta Tester

Hi Eric

Thanks for the explination - I understand the principal, but can not get it to work.

I have put the echo statement within a hidden form field and have created an update behaviour using DA which updates this hidden field however nothing is getting updated.

the server behaviour is;


// WA Application Builder Update
if (isset($_POST["LogIn_x"])) // Trigger
$WA_connection $lsdogs;
$WA_table "users";
$WA_redirectURL "index.php";
$WA_keepQueryString false;
$WA_indexField "id";
$WA_fieldNamesStr "logged_in";
$WA_fieldValuesStr "".((isset($_POST["time"]))?$_POST["time"]:"")  ."";
$WA_columnTypesStr "none,none,NULL";
$WA_comparisonStr "=";
$WA_fieldNames explode("|"$WA_fieldNamesStr);
$WA_fieldValues explode("|"$WA_fieldValuesStr);
$WA_columns explode("|"$WA_columnTypesStr);
$WA_where_fieldValuesStr "".$_SESSION['id']  ."";
$WA_where_columnTypesStr "none,none,NULL";
$WA_where_comparisonStr "=";
$WA_where_fieldNames explode("|"$WA_indexField);
$WA_where_fieldValues explode("|"$WA_where_fieldValuesStr);
$WA_where_columns explode("|"$WA_where_columnTypesStr);
$WA_where_comparisons explode("|"$WA_where_comparisonStr);
$WA_connectionDB $database_lsdogs;
  if (!
session_id()) session_start();
$updateParamsObj WA_AB_generateInsertParams($WA_fieldNames$WA_columns$WA_fieldValues, -1);
$WhereObj WA_AB_generateWhereClause($WA_where_fieldNames$WA_where_columns$WA_where_fieldValues,  $WA_where_comparisons );
$WA_Sql "UPDATE `" $WA_table "` SET " $updateParamsObj->WA_setValues " WHERE " $WhereObj->sqlWhereClause "";
$MM_editCmd mysql_query($WA_Sql$WA_connection) or die(mysql_error());
  if (
$WA_redirectURL != "")  {
    if (
$WA_keepQueryString && $WA_redirectURL != "" && isset($_SERVER["QUERY_STRING"]) && $_SERVER["QUERY_STRING"] !== "" && sizeof($_POST) > 0) {
$WA_redirectURL .= ((strpos($WA_redirectURL'?') === false)?"?":"&").$_SERVER["QUERY_STRING"];
header("Location: ".$WA_redirectURL);

I wonder if it is the key column on the first page of the wizzard that is the problem?

I have removed the success redirect from the authentication behaviour and have inserted it into the update so that the user does not get redirected before the script has run.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...