close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

PayPal Advanced passing shipping address but not ship to name

Thread began 6/27/2017 12:34 pm by TroyD | Last modified 6/27/2017 8:52 pm by TroyD | 325 views | 6 replies

TroyD

PayPal Advanced passing shipping address but not ship to name

I am starting a different thread here because this is a different issue in the same setup I posted earlier (found here http://www.webassist.com/forums/post/208901/)

This one has to do with shipping addresses. My client pointed out that when he logs into paypal.com the "Print Shipping Labels" button is missing for all transactions that were done using a credit card on the website. In other words, they don't log into PP, they just use their cc.

We have been back and forth with PayPal about this and once they even admitted that they were aware of the problem and they were fixing it. However, now they say I am not passing the information correctly. They won't tell me what or why, which is odd.

When I log into the manager.paypal.com account, I see both the billing and shipping addresses in the transaction details. However, I did notice that the customer's name is only showing up with the billing address. The shipping address is missing the person's name. The address is there, but no name. When reading the docs, it doesn't mention anything about this. It simply says...
"Note: If you pass in any of the ship-to address parameters such as SHIPTOCITY or SHIPTOSTATE, you must pass in the complete set (that is, SHIPTOSTREET, SHIPTOCITY, SHIPTOSTATE, SHIPTOCOUNTRY, and SHIPTOZIP)."

I do know that the name is being passed as FIRSTNAME and LASTNAME but I do not find anything like SHIPTOFIRSTNAME. Is this suppose to be there? Am I missing a variable?

It seems like I am missing something because I have both a billing and shipping form and the shipping form includes the field "First_Name_2" and "Last_Name_2". The billing form uses "First_Name" and "Last_Name".

All of the address information, SHIPTOSTREET, SHIPTOCITY, SHIPTOSTATE, SHIPTOCOUNTRY, and SHIPTOZIP, is included but I don't see anything for the ship to name. Where should I be looking?

Any thoughts?

Thanks,
TroyD

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...