View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

The dreaded Error Initializing UI...

Thread began 9/22/2009 2:47 am by Stevebo | Last modified 9/23/2009 7:53 pm by Stevebo | 1789 views | 5 replies


The dreaded Error Initializing UI...

I think this may be akin to blue screen of death. Anyway, I after doing lots of work on my form, I was in the Edit Form mode when editing something rather small. I clicked Finish and got an error part of the way through FB saving the code. The error showed up as a DW error (see the attached file). Once this occurred, anytime I attempted to use Edit Form and clicked the edit icon, it would attempt to start but then I'd see the Error Initializing UI, Type Error: groupObj has no properties.

I got a prompt to show the errors and I took a snapshot so you can see them.

I tried deleting the WinDat cache file, uninstalling the extension, then reinstalling it, then firing up DW again and when trying to edit the form, I get the same error. I can click on Edit Design and make a small change and save everything and that works fine. The problem is when I go to Edit the form. Note that I'm using a preset I created that was working fine until all of a sudden it stopped.

I tried creating a new file and using the same preset. After the form was inserted I clicked on edit form and it showed the contents of the form just fine. Then when I clicked Finish, the same error message popped up about a spry widget no longer being present and might not work OK. It seems to have something to do with this:

var Security_info_group_Security_code_Spry = new Spry.Widget.ValidationTextField("Security_info_group_Security_code_Spry", "none",{validateOn:["blur"]});
var Security_info_group_nbsp_Spry = new Spry.Widget.ValidationTextField("Security_info_group_nbsp_Spry", "none",{validateOn:["blur"]});

These are the last two lines of var definitions at the end of the javascript at the end of the page.

Any idea what's causing this? Am I going to have to build my form from scratch to get around this? anything I could edit on my own to fix the problem with the preset?

Note that if I don't use this preset that must have become corrupted somehow, and use a standard FB form type such as simple registration, I can use the Edit form mode just fine without causing the above problems.


Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...