close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

I've included the mysqli update records on a page and nothing is happening

Thread began 1/23/2015 12:44 am by dionysus224892 | Last modified 1/23/2015 11:57 am by dionysus224892 | 402 views | 1 replies

dionysus224892

I've included the mysqli update records on a page and nothing is happening

I've put in a URL to go to after updating, and it does redirect, but the script seems to skip the updating part.

Here is the code : pretty standard code from you.

if ((((isset($_POST["updateme"]))?$_POST["updateme"]:"") != "")) {
$UpdateQuery = new WA_MySQLi_Query($ehs);
$UpdateQuery->Action = "update";
$UpdateQuery->Table = "evenements";
$UpdateQuery->bindColumn("etitre", "s", "".((isset($_POST["etitre"]))?$_POST["etitre"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("esoustitre", "s", "".((isset($_POST["esoustitre"]))?$_POST["esoustitre"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("edescription", "s", "".((isset($_POST["edescription"]))?$_POST["edescription"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("edescmini", "s", "".((isset($_POST["edescmini"]))?$_POST["edescmini"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("edate", "t", "".((isset($_POST["edate"]))?$_POST["edate"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("edate2", "t", "".((isset($_POST["edate2"]))?$_POST["edate2"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("emod", "t", "$today", "WA_DEFAULT");
$UpdateQuery->bindColumn("etype", "s", "".((isset($_POST["etype"]))?$_POST["etype"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("eactive", "c", "".((isset($_POST["eactive"]))?$_POST["eactive"]:"") ."", "WA_DEFAULT");
$UpdateQuery->bindColumn("epic", "s", "$lefilename", "WA_DEFAULT");
$UpdateQuery->addFilter("eid", "=", "i", "".($_POST['eid']) ."");
$UpdateQuery->execute();
$UpdateGoTo = "";
if (function_exists("rel2abs")) $UpdateGoTo = $UpdateGoTo?rel2abs($UpdateGoTo,dirname(__FILE__)):"";
$UpdateQuery->redirect($UpdateGoTo);
}


So what could be going wrong? I'm using the same connection script as used for grabbing data from the db so that should work the same, no? And if not, I'd expect some type of error message. So what could be happening here?

Thanks very much,
George

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...