close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

Error message when sending email mail shots based on a looping recordset

Thread began 6/05/2013 10:52 am by iainmacdonald331081 | Last modified 6/05/2013 1:33 pm by iainmacdonald331081 | 364 views | 5 replies

iainmacdonald331081

Error message when sending email mail shots based on a looping recordset

This has been an issue for a while. Initially the problem was that too many emails were being sent by the server, but that was resolved by adding limits to the number of emails sent.

And more recently I set it up so that when the site owner is sending these mailshots, a new window opens, and have added a progress bar, so that he has some visual feedback whilst emails are being sent, and can get back to the rest of the site in the original window.

And in testing, it all seems to work perfectly.

However, I still here from him sometimes to say its failed, with the error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@searchtechuk.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I have been in touch with the hosting company who are not seeing any errors, for example relating to too many mails being sent.

The only thing showing on any error logs is the error:

Parameter 2 to Trigger_Default_FormValidation() expected to be a reference, value given in /home/searchte/public_html/includes/tng/tNG.class.php on line 228

Although I think that's a red herring as the log is littered with that error, suggesting its not related to the one above. Plus I don't think that tNG.class.php (an old ADDT file) is being referenced as part of the UE function.

The only other thing the hosting company could think of was that there might be a maximum execution time for the script.

If that is the case, can it be changed, or can it be set to send smaller batches, reset, and continue sending?

Although when it failed earlier today, it was sending 177 emails. The settings were to wait 14 seconds between emails, and send a max of 4 per minute, which doesn't seem like that large a recordset.

Any advice much appreciated.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...