close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

FedEx calculator working...but not...??

Thread began 7/11/2011 3:49 pm by angelleye | Last modified 7/11/2011 4:10 pm by angelleye | 772 views | 1 replies

angelleye

FedEx calculator working...but not...??

I haven't had any problems with UPS or USPS but my FedEx rule just doesn't seem to be kicking in for some reason.

I used the server behavior to add FedEx shipping and went through the wizard accordingly. It added a FedEx rule to my Shipping tab in the eCart Panel as expected. I went ahead and added 2.50 to this like I always do with eCart shipping rules. Then I synced everything with my server.

When I go through the FedEx calculator now I do end up on my success page, however, the FedEx rule simply isn't applied. To troubleshoot, I added the FedEx Full Request and Full Response to the very bottom of my success page. The thing is, everything looks just fine. Here's what I'm getting back from FedEx for a Priority Overnight request...

  <FDXRateReply xsi:noNamespaceSchemaLocation="FDXRateReply.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:env="http://schemas.xmlsoap.org/soap/envelope/" xmlns:m="http://com/fedex/ws/transform">
<ReplyHeader/>
<EstimatedCharges>
<DimWeightUsed>true</DimWeightUsed>
<RateScale>1530</RateScale>
<RateZone>4</RateZone>
<CurrencyCode>USD</CurrencyCode>
<BilledWeight>7.0</BilledWeight>
<DimWeight>7.0</DimWeight>
<DiscountedCharges>
<BaseCharge>62.50</BaseCharge>
<TotalDiscount>10.00</TotalDiscount>
<Surcharges>
<DeclaredValue>2.25</DeclaredValue>
<VAT>7.88</VAT>
</Surcharges>
<TotalSurcharge>10.13</TotalSurcharge>
<NetCharge>62.63</NetCharge>
<TotalRebate>0.00</TotalRebate>
</DiscountedCharges>
</EstimatedCharges>
<SignatureOption>NONE</SignatureOption>
<Routing>
<ServiceCommitment>A1</ServiceCommitment>
<OriginServiceArea>A2</OriginServiceArea>
</Routing>
</FDXRateReply>  



Again, though, when I end up back on my shopping cart or any page that displays shipping the FedEx amount simply isn't applied. My shopping cart is setup to display each shipping amount separately and when I end up back there it'll show USPS and UPS (if those have been calculated at any point) but it never includes FedEx.

I'm not really sure what to do at this point. I went ahead and re-uploaded the entire WA_eCart directory just to make sure the sync wasn't doing something funny and that didn't help.

Any information on what's going wrong here would be greatly appreciated. Thanks!

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...