close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Stuck on a 404 page

Thread began 11/06/2009 9:27 pm by clickhappy392103 | Last modified 1/15/2010 3:45 pm by neilo | 2470 views | 12 replies |

clickhappy392103

Stuck on a 404 page

Okay, I am stuck again. I started all over, and I am using xampp as my testing server. At this point, I am not defining my live server yet. I want to work on figuring this out b4 uploading anything. I have been following the PowerCMS Getting Started Guide step by step. I am up to step 5, creating your page content ( I skipped step 4 since I am just on a local server).
I created an index.html landing page with a text link that takes me to the login screen. I can log in fine, according to step 5.. next I click on Insert New Content. When I do that I get a 404 error...actually when I click on any of the 4 tabs I get a 404 error. So I am assuming I messed something up in my Globals?
I built a blank php page for editing.
This is where my files are on my computer

C:/xampp/xampp/htdocs/pcms/cms100
pcms is the root folder for Dw settings

I noticed that for some reason the xampp folder is doubled for some reason

these are my globals
<?php
$WAGLOBAL_Root_URL = "http://localhost/pcms/" ; //Absolute path to your site folder.
$WAGLOBAL_Site_Name = "Content Management Area" ;

$WAGLOBAL_localRoot = "/CMS100/"; //relative path to your PowerCMS files on your local testing server.
$WAGLOBAL_remoteRoot = "/PowerCMS folder/"; //relative path to your PowerCMS files on your remote server.

//iRite Images upload settings
$WAGLOBAL_Images_Folder = "images/"; //relative path to your images folder.
$WAGLOBAL_Swf_Folder = "swf/"; //relative path to your swf folder.

// Admin Settings
$WAGLOBAL_Admin_UserName = "test" ;
$WAGLOBAL_Admin_Password = "test" ;
?>

I know I shouldn't post password/login...but this is just on my pc for learning

I will attach a screenshot of my files layout in DW

What am I doing wrong? Am I supposed to be saving my pages inside the CMS100 folder or something?

Sign in to reply to this post

clickhappy392103

still stuck

well I went in and changed my globals several times to every configuration I could imagine with the same result every single time. So then I thought maybe I would just put in my live server settings and upload it to try it that way. After doing that, I was able to get to the add content page. But when I added content ad clicked done...I got another error 404.

I have been reading posts about global misconfigurations until my eyes hurt. Why can't the documentation give better examples. I just don't get it. This shouldn't be this difficult. Why can't WA just give a bare bones, talk to me like I am 5 years old, first time ever messing around with this type of stuff pdf documentation. You would think that it would solve a large amount of people getting very angry and frustrated, like myself. I have to say that I am starting to get fed up with this product.

Heck I still can't even figure out if the files that I extracted are supposed to be inside of their own file folder inside of my site folder or if it is okay to have a structure like my jpeg above.

Sign in to reply to this post

clickhappy392103

beating a dead horse

While I am waiting on a reply to the first post questions, I have another. When setting up my site folder in Dw I set an images folder. Then CMS100 has an images folder also, which one am I supposed to be using for image uploads? Or is the images folder that came with cms supposed to be my root images folder?
I am still trying to read more info on this global stuff and had to chuckle when there is a 4 page pdf on how to set up 1&1 hosting, and database on 1&1. But not 1 sentence on the preferred site structure for this product in DW.

Sign in to reply to this post

neilo

Hiya clickhappy392103,

If you want to follow a known-to-be-working installation, I have documented my exact steps and settings in a pdf doc Here

Sign in to reply to this post

paul368601

Your PDF link doesn't work - I'm frust. like clickhappy.

Originally Said By: neilo
  Hiya clickhappy392103,

If you want to follow a known-to-be-working installation, I have documented my exact steps and settings in a pdf doc Here  



A few people have mentioned you...and I'm frustrated with this like Clickhappy was. Tried your link but it is disconnected....how do I get your instructions?
If I can't get this Power CMS going I'm moving on to another product and not looking back. Thanks. - Paul

Sign in to reply to this post

neilo

Hiya Paul,

I removed the pdf, as I think that the latest version of PowerCMS (1.0.2) and its documentation have largely addressed the issues that people seemed to be having problems with.

My doc can still be good for a step-by-step guide in conjunction with the latest documentation.

I have put the pdf back where it was before. Here

Note: The 'downloadable fix' referred to in the pdf is no longer a necessary step if you are using the latest downloadable files, so ignore that bit. You should also ignore step 3! This has been corrected in the latest release.

All of which doesn't leave very much, which is why I removed it.

If you have any specific queries or difficulties, then you could start a new thread.

Sign in to reply to this post

clickhappy392103

Hot Dog!

okay I think I got it sorted out. For any other newbie like me, here's what I did. I think I had 2 things messed up because I tried both of these seperately but it didn't work until I started over again and implemented both of these. First off, copy the files from the folder to your site and paste them in...but don't copy the cms100 folder they came in..just the internal folders. Secondly...and this is part is totally my screwup, I am using xampp, and evidentlly you need to set up a new user for your db because it just wouldn't let things work for me with the default superUser of root.

So hopefully, this will work again once I upload it to my live server. Knock on wood.

WA Admins...please please add a little extra starter instructions for us newbies..I killed a good 2 days and Lord knows how many braincells !

Sign in to reply to this post

clickhappy392103

ahhh Neilo..where have you been ?? HA
I was just posting that I figured it out and then saw your post. I will definately read your info to see if mine is really right or not.. I think you and office guy should post your home numbers on here for us to call for pointers :)
all kidding aside, thank you for taking the time to make that...maybe WA will include it in their files (hint hint)

Sign in to reply to this post

neilo

I'm not in OG's league, (dammit!) - having taken to PHP like a duck to concrete. But I do have a stubborn streak and rather too much time on my hands.

Hope the doc helps someone!

Really glad you got things working.

Sign in to reply to this post

web364946

well neilo, let me know if you are ever coming over to Sweden and I will invite you over for cake - thanks a million for your brilliant document! CanĀ“t even begin to tell you what a relief to my head ache it has been!

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...