close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Upload problems

Thread began 9/23/2009 11:23 am by info269075 | Last modified 9/23/2009 4:38 pm by anonymous | 1012 views | 3 replies |

info269075

Upload problems

Ok i may say i tried 10 times on 10 differents web sites I never succeed to make working the irite image upload. I don't undestand why there is always a problem on local or remote server. The path are never good. I tried once more and the problems goes on again, maybe some one could tell me what's wrong. I'm on a local sever, i'm working on a back office so i use an absolut path this if my config:

$Config['Enabled'] = true ;

$Config['UserFilesPath'] = 'C:/wamp/www/website/imgs/' ;
$Config['UserFilesAbsolutePath'] = 'C:/wamp/www/website/imgs/' ;

when i open the editor i can create a new directory inside the imgs folder but if i try to upload an image it always says "invalid file", it's just a jpg !

I'm really tired of this pluggin, but if someone understand what's wrong
thanks

Sign in to reply to this post

anonymous

Hi there,

A couple of things look out of place.

First,

$Config['UserFilesPath'] = 'C:/wamp/www/website/imgs/' ;

This attribute is not an absolute path but rather it needs to be set relative to the document root... so if your site is in the "website" folder, this setting should look like this:

$Config['UserFilesPath'] = '/imgs/' ;

The second - which you can fill if you prefer to specify the absolute path - is not always necessary... in fact, I would leave it blank like this:

$Config['UserFilesAbsolutePath'] = '' ;

Then, make sure you have the permissions set on the folder "imgs". Even if it is on a testing server, you will have to be sure to CHMOD probably to 755 at least - maybe even 777.

Once you do that, you should be good to go.

Best regards,

Brian

Sign in to reply to this post

info269075

thanks

In fact it works like this - I'm on a local server.
/website/imgs/

But I still have a weird problem, if i put an image in the folder, i can see it in the Irite window, but when i try to ulpoad it says " invalid file", with gif, bitmap, jpg...
i'm on windows vista.

thanks

Sign in to reply to this post

anonymous

Ok... glad you got the folder issue worked out... for the other problem, my next question is are you running PHP on IIS Server or Apache? It still sounds like there is a permissions problem on your folder.

Best regards,

Brian

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...