close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

> Hello I'm having trouble using the data bridge 2

Thread began 1/17/2019 1:31 pm by olivier | Last modified 1/24/2019 1:47 pm by Ray Borduin | 54 views | 5 replies |

olivier

> Hello I'm having trouble using the data bridge 2

Hello I'm having trouble using the data bridge 2 wishing to test its features, I created a basic site using Extender design and then I tried to create security pages to secure the pages of the site.

During this phase the software could not save the login.php page.

The procedure for managing the pages of the site associated with the creation of the security pages gave no result.

I took over this task using the access pages manager function, which worked this time but was unable to save the login.php page again;
during this security phase, I also encountered a problem in creating the ps4_Users table in the database.

The software could not create it even though the connection is quite functional.

I thought it was because there was this empty table in my database.

So I deleted it, I redid the maneuver and the creation was still not possible.>
So I had to create the table manually to check everything works in access to this table.

On the other hand, the files created do not allow access to the pages of the site. Indeed, they create a redundant redirect that blocks the access to the page.
I give you the address of the site so that you can check: http://test.instantpresent.eu

I am working with Dreamweaver CS6.
Thank you for the help you can give me to correct these bugs.

Sign in to reply to this post

Ray BorduinWebAssist

I'm having a hard time figuring out what exactly is going wrong. Let's just work on one thing at a time. The first issue you mention is:

"During this phase the software could not save the login.php page."

What do you mean it could not save the page? Did you get an error? Please describe in detail what exactly you did to get to this problem and what errors or issues you see. Maybe attach a copy of that page and I can take a look at the code on it.

Sign in to reply to this post

olivier

I will try to explain more clearly

1. After creating a basic site with building a site then I launch the creation of security pages.
I first create a connection to a newly created database and then test and validate it. I then get a curious error message see picture 1.

2. I click OK and the creation of the security pages continues.
I get a second error message when creating the log out page (see image 2) "can not save documents when searching for associated files"
I click OK and the creation of the security pages ends.

3. Then begins the phase Management site access.
I select the rule "connected to the user database" and start the process of securing pages.
I get an error message saying that the user table could not be created and that I have to contact the web assist user service (see image 3)
Nevertheless after checking the table exists well.

4. After uploading the files to the server I attempt a connection. Here is the url created by the WebAssist files and the associated error message (see image 4)
url : http://test.instantpresent.eu/?accesscheck=%2Findex.php%3Faccesscheck%3D%252Findex.php%253Faccesscheck%253D%25252Findex.php%25253Faccesscheck%25253D%2525252Findex.php%2525253Faccesscheck%2525253D%252525252Findex.php%252525253Faccesscheck%252525253D%25252525252Findex.php%25252525253Faccesscheck%25252525253D%2525252525252Findex.php%2525252525253Faccesscheck%2525252525253D%252525252525252Findex.php%252525252525253Faccesscheck%252525252525253D%25252525252525252Findex.php%25252525252525253Faccesscheck%25252525252525253D%2525252525252525252Findex.php%2525252525252525253Faccesscheck%2525252525252525253D%252525252525252525252Findex.php%252525252525252525253Faccesscheck%252525252525252525253D%25252525252525252525252Findex.php%25252525252525252525253Faccesscheck%25252525252525252525253D%2525252525252525252525252Findex.php%2525252525252525252525253Faccesscheck%2525252525252525252525253D%252525252525252525252525252Findex.php%252525252525252525252525253Faccesscheck%252525252525252525252525253D%25252525252525252525252525252Findex.php%25252525252525252525252525253Faccesscheck%25252525252525252525252525253D%2525252525252525252525252525252Findex.php%2525252525252525252525252525253Faccesscheck%2525252525252525252525252525253D%252525252525252525252525252525252Findex.php%252525252525252525252525252525253Faccesscheck%252525252525252525252525252525253D%25252525252525252525252525252525252Findex.php%25252525252525252525252525252525253Faccesscheck%25252525252525252525252525252525253D%2525252525252525252525252525252525252Findex.php%2525252525252525252525252525252525253F
I specify that at this stage I made no change to the code created by WebAssist.

I hope this will help you understand my problem and I remain vigilant to complete and answer your questions.
Thanks for your help

Attached Files
logout.php
Sign in to reply to this post

Ray BorduinWebAssist

1.) This can be ignored. It was a leftover message from debugging that I'll get removed, but it is inconsequential. I'll update a fix for that right now.

2.) Do you have your site sync settings configured to put on each save and include dependent files? There are a lot of updates and saves going on at once, this might be causing this issue. Perhaps turning off that setting would help the page to generate properly.

3) This is usually an issue with the connection. I wonder if the problem in step 2 caused some pages to not be uploaded and that is the problem in step 3.

4) It looks like you accidentally added the "Restrict Access To Page" server behavior to the index.php page that has the login, or maybe you just specified the wrong page name in the "Restrict Access To Page" server behavior. The server behavior should never point to itself. So it either should not be on the index.php page, or it should go to the user_login.php page when it fails.

Sign in to reply to this post

olivier

Logout or not logout?

Hello Ray,
Thank you for your help and explanations. I have corrected the index.php file and the login.php file and now the connection is working properly.
However, I have another question if you want: logout.php logout procedure seems to work normally; she announces that the disconnection has been made. However, if I try a connection on one of the pages of the site, I can access it without any problem without needing to identify me again. Do you have any idea what is causing this dysfunction?
Thank you for your lights or tell me where the answer is if I did not find it.

Sign in to reply to this post

Ray BorduinWebAssist

Any page you don't want accessed should have the restrict access server behavior. Try closing your browser and accessing the page before logging in. If you can't, then the issue is with the log out not working. If you can, then the page isn't properly restricted to begin with.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...