close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

setting up new mysqli databse connection gives http error code 500 internal server error

Thread began 3/18/2018 4:44 pm by Janet | Last modified 3/26/2018 1:21 pm by Ray Borduin | 161 views | 6 replies |

Janet

setting up new mysqli databse connection gives http error code 500 internal server error

Hi there,

tried to set up a new database, and got the error code above on two separate MySQL databases I tried. I have attached a private link to an image and more details to see if you can recreate the error. I am using Dreamweaver version 18.0

Sign in to reply to this post

Ray BorduinWebAssist

Usually this is a problem with the website url specified in the Dreamweaver Site settings for your testing server. Can you send me a screenshot of that page. I can maybe use that to reproduce it.

Sign in to reply to this post

Janet

I've attached the screen shots as requested, plus a screen shot of the connection using Navicat, which connects to the database correctly. GoDaddy limit remote access through IP address, and I will need to add yours to the cpanel so you can test it.

Sign in to reply to this post

Ray BorduinWebAssist

If you provide a US phone number or Skype contact information I can set up a screen sharing session to help you debug this. Your connection information appears correct. This is the "testing server" connection you sent right? That is the one that is used and it must be defined.

Sign in to reply to this post

Janet

Hi Ray. That wasn't the testing server details, but the testing server mirrors it exactly, I have attached a screenshot in private along with contact details too.

Attached Files
MMHTTPDB.php
WA_DBScript.php
error_log.txt
mysql.php
Sign in to reply to this post

Ray BorduinWebAssist

We looked into this in a screen sharing session and the solution was to use "localhost" as the database server name.

Sign in to reply to this post

Janet

Hi Ray, thank you so much for helping with this! To add a footnote... linking up with the IP address rather than localhost also works now, GoDaddy had an issue on their end, and removed the bug.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...