close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Server updated php 5 6 5 3 - help guide through fixes

Thread began 8/20/2017 2:10 pm by Brendan | Last modified 8/21/2017 5:08 pm by Ray Borduin | 127 views | 5 replies |

Brendan

Server updated to php 5.6 - Need help fixing login and ecart pages

Our server was still running PHP5.3, and after an update to php5.6 I am having some issues.

My add to cart buttons are working fine, and security assist secure pages seem to be working, but my log in page is blank, as is my checkout page.

The update was done without our knowledge, now I have a client who's store is down. From other posts, it looks as though everything should work. I don't know if this is related, but I am unable to access the site database tables remotely with Navicat, so I'm wondering if since the pages that aren't working all interact with the database tables, that this is affecting page loads?

Sign in to reply to this post

Ray BorduinWebAssist

I'd need FTP access to debug. We could do it in a private session, but I should be able to figure it out quickly and wouldn't need to charge you if you just send me:

1) A url to the page that won't load
2) FTP access to the site so I can debug and make any necessary changes.

Sign in to reply to this post

Brendan

There are a lot of pages with duplicate functions, but if we can get these to work, I think I can update the rest.

https://run4fundscolorado.com/cottonwood/student-search.php - this page has a requirement of "logged into users", the redirect to the login page is where the failure is occurring

The results page is https://run4fundscolorado.com/cottonwood/student-results.php

https://run4fundscolorado.com/cottonwood/ - if you add an item to the cart, and proceed to checkout, the checkout.php page is not loading.

Sign in to reply to this post

Ray BorduinWebAssist

I've turned on error display on that page and it looks like your database connection information is wrong. The solution is to update the connection in the Connections/run4funds.php page.

Sign in to reply to this post

Brendan

I changed the password after migration, and forgot about the connections file. I have corrected that, and it looks like most issues are resolved. After running a transaction, i'm getting a blank confirm.php

Sign in to reply to this post

Ray BorduinWebAssist

I called and helped you debug and fix this over the phone. It turned out you had to run a database repair and that fixed it. It must have been another issue with the migration.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...